"Method failed.HRESULT = 0x80070057 : The parameter is incorrect" in AGS 10.1 log

30187
23
12-07-2012 09:33 AM
TomCohen
Occasional Contributor
I have several map services running on the same server / AGS instance and one of them, which sources all its data from File GeoDatabases (which are registered folders on the server) periodically logs the following message in AGS (tagged SEVERE).

Method failed.HRESULT = 0x80070057 : The parameter is incorrect


The service is configured to always draw data dynamically, and has never been configured to create / use a tile cache. However, it also periodically logs

Failed to rename cache folder


This message is also tagged SEVERE. There doesn't seem to be any issue rendering data, and rendering time is good, so I have no idea if this is a problem or not.

Any suggestions on what's going on here would be much appreciated.
Tags (2)
23 Replies
GabiVoicu
Occasional Contributor

Two more versions pass by and sure enough coming across exact same error in ArcGIS Server 10.3

Method failed.HRESULT = 0x80070057 : The parameter is incorrect

The service looks fine in the rest point as well as the query on a certain layer but the app does not display this one layer in particular from the service that throws this error ...it's not consistent either ...

It's been a while since this post was started - is anyone else is seeing this error in 10.3 ?

Thank you

0 Kudos
ChrisJensen
New Contributor III

I am getting this error in 10.3.1 while trying to publish an editable feature layer, followed by 'Failed to rename cache folder' error

0 Kudos
GerardEddy
New Contributor

Is this still an issue for anyone?  Has anybody come across this error in relation to  a Dynamic Service?  There is no cache associated with the service.  Niels' links were dead ends.  one was a 404 error, the other gave a "site error" and informed me the administrator was notified.

Was/Is this a known bug with respect to dynamic services?

Thanks all, in advance.

0 Kudos
AndyBradford
New Contributor

I'm getting this error, and it seems to be causing a service publish to fail. We have a third-party SOE that has to be enabled in the service's Capabilities to function, and this error message appears as it's failing. It works if the service is pushed without the SOE, but if I enable it it fails.

0 Kudos
KarenFolger
Occasional Contributor II

I am getting this same error publishing at 10.5.1. I made sure that my ArcGIS Server Service account had all the permissions to the Cache folder and all the other arcgiserver folders and that they were not read-only. I re-published several services and got this same sequence of errors on every service. They are dynamic feature services from a file geodb on the same server. The services do work but excessive logging concerns me. All errors are SEVERE:

Failed to rename cache folder.

Method failed.HRESULT = 0x80070057 : The parameter is incorrect. . - for the Source service - this msg shows twice.

0 Kudos
ApurvDanke
Occasional Contributor

Hi,

I am also having the issue as given below in ArcGIS Server logs.

In my case, I have a web service which calls the "ExportMap" method of ArcGIS Server REST API for a particular dynamic map service to generate a map image for a given extent. In few cases such as mentioned above, the web service fails to generate a map image because of the errors mentioned above in ArcGIS Server logs. When I checked the same scenario again, the image was retrieved successfully and generally it works. It is these one off cases where I've observed that it fails. I am using ArcGIS Server 10.4.1. Any suggestions?

Regards,

Apurv

0 Kudos
CesarAlvear
New Contributor

Encontré la solución aquí, en mi caso funciono..!

The solution here.!

BLOG DE CMAV: Method failed.HRESULT = 0x80070057 : The parameter is incorrect. . 

TaraPreston
New Contributor III

Hi Cesar. Do you by chance know if this has been translated into English anywhere? Thanks.

0 Kudos
DavidHorsey1
Esri Contributor

Hi Tara. Open the link in Chrome and it'll translate the page for you.

This error code and message can also be seen in other applications. Has anyone in the thread tried to do the registry tweaks mentioned in this article - Error Code 0x80070057 - Causes and Methods to fix it | Fix Errors

Change you make to the registry are done at your own risk, etc, etc

0 Kudos
DaveSivertsen
New Contributor III

This link is no longer valid. Anyone care to post the solution that used to be there?

We have this issue as well.

Thanks.