Why might the base map gallery and other tools/widgets in Portal 10.3.1 not work in created map app?

247
6
10-11-2018 10:50 AM
SamuelPerez1
New Contributor III

My organization is currently using Server and Portal 10.3.1, and I have created and published map viewer app for one of our departments. Each user in the mentioned department has their own seat (sign in credentials), and are members of the group I set up for that department.  The map viewer app has been shared to both the group and whole organization, yet for some reason a few of the users in the group are unable to use the basemap gallery and other tools/widgets such as the print tool in the map viewer app. The widgets appear in the app, however they do not render anything when clicked on. Any ideas on why this might be, and/or how to solve this issue?

0 Kudos
6 Replies
DerekLaw
Community Moderator

Hi Samuel,

I am not clear on which app you're referring to about this issue.

> ... I have created and published map viewer app ...

Can you please be more specific? Did you deploy a new web app using one of the configurable app templates? If so, which one? There is a list here,

Choose a configurable app—ArcGIS Online Help | ArcGIS 

> ... The widgets appear in the app ...

Or when you mention "widgets", did you perhaps use Web AppBuilder for ArcGIS to create and deploy your web app?

Hope this helps,

SamuelPerez1
New Contributor III

Hi Derek,

Yes, I did use a configurable app template. I used the 'Basic Viewer'. 

Also, I did not use WebAppBuilder. My apologies. I used the word widget instead of tool.

0 Kudos
DerekLaw
Community Moderator

Hi Samuel,

Apologies for the late reply. I have been out of the office on business travel the last few weeks.

So, you've built a new web app (with the Basic Viewer template) in Portal for ArcGIS 10.3.1, shared the app to a group. Some members of the group can access all the tools in the app, while for others, the tools are greyed out - is that correct?

Do all the users have the same permissions/access capabilities in Portal? To both the app and its datasets? Are they all the same level, for example, level 2 to access edit capabilities?

Hope this helps,

0 Kudos
SamuelPerez1
New Contributor III

Hi Derek,

No worries!

Correct, I have built a new web app (with the Basic Viewer template) in Portal for ArcGIS 10.3.1, and then shared the app to a group. The members I have spoke to, have had the same issues not being able to access certain tools in the viewer, such as the print button. All the members of the group are level 2 users, set to 'User' permissions. 

I am getting ready to upgrade to Enterprise 10.6.1, might this clear up this issue?

0 Kudos
DerekLaw
Community Moderator

Hi Samuel,

For clarification,

> ... The members I have spoke to, have had the same issues not being able to access certain tools in the viewer, such as the print button.

Does this only happen to some Portal members, but not all members? or does this happen to all Portal members? If the latter, perhaps this topic may help:

Configure the portal to print maps—Portal for ArcGIS (10.3 and 10.3.1) | ArcGIS Enterprise 

> I am getting ready to upgrade to Enterprise 10.6.1, might this clear up this issue?

Maybe. I always recommend upgrading software to the latest release when possible.

Hope this helps,

SamuelPerez1
New Contributor III

This did in fact do the trick! Thank you for your help!

0 Kudos