webgisdr - "Cannot get ancestors in the response of the request:"

565
9
04-28-2021 06:16 PM
Labels (1)
DeanHowell1
Occasional Contributor III

I am trying to run an webgisdr incremental backup and it worked the first time but I am now getting the following error: "Cannot get ancestors in the response of the request:"

Does anyone know what this means?

Tags (3)
0 Kudos
9 Replies
DavidHorsey1
Esri Contributor

What version are you running? BUG-000112342 relates to an issue that gave the same error message.

This was fixed in 10.7.0.

0 Kudos
DeanHowell1
Occasional Contributor III

Thanks @DavidHorsey1 we are running 10.7.1 but don't have any spatiotemporal datastores set-up, just relational and tilecache. 

0 Kudos
vanand
by
New Contributor

HI @DeanHowell1 

Was webgisdr used to restore this environment at any time in past before this message came up?

Regards

Vagish

0 Kudos
DeanHowell1
Occasional Contributor III

Thanks @vanand not that I am aware of but maybe it was used when it was upgraded from 10.6.1 to 10.7.1 but that was before my time 🙂

0 Kudos
ChrisCarter3
New Contributor II

I am getting the same error in Enterprise 10.8.1. I am able to restore a full backup, but then when I try to restore the incremental backup, I get the same error that the OP gets. It references the data store, but PITR is enabled on the source and destination data stores.

DavidRunneals4
New Contributor III

YES! We are having the SAME issue on 10.8.1 and working with support, to no luck yet. Anyone have any case numbers to share so our analysts can get together on this one? Our case # is 02798351

0 Kudos
DavidRunneals4
New Contributor III

@DeanHowell1 @ChrisCarter3 This has been added as BUG-000139701. I've escalated it, but you should probably also get on the bug as well.

0 Kudos
ChrisCarter3
New Contributor II

My case number is 02801852. Let's hope they can figure this out!

0 Kudos
JonathanQuinn
Esri Frequent Contributor

The bug is specific to having the tile cache data store registered, but not included in backups. If you don't publish scene services, including the tile cache data store in the WebGIS DR backup shouldn't increase backups times, (and work around the bug).

0 Kudos