Top Navigation Links redirect to HTTP

1039
4
Jump to solution
11-29-2016 01:42 PM
LucasScharenbroich
Occasional Contributor

So, a very strange situation ... I've installed Portal for ArcGIS several times and have never seen this behavior. When I click on the top navigation links I am getting redirected from the HTTPS protocol to HTTP.  The installation is very standard:

  • Portal installed on a dedicated machine with its Identity store pointed to Active Directory.  Portal has not been reinstalled and the underlying machine name has not changed.
  • A Web Adaptor is installed on a separate IIS web server on a separate machine.  Anonymous access is enables and a valid certificate is installed that was issued by AD CS.

Now, the strange behavior is that, whenever I click on the top navigation links, "My Content", "Groups", etc.  I am getting redirected to an HTTP url.  This behavior is consistent across browsers.  I've included screenshots from IE and Chrome.  Firefox behaves the same as Chrome.

Anyone know what is causing this problem and how it can be fixed?  I have restarted Portal and reviewed the "self" REST endpoint and looked at the page source, and I do not see any place where an explicit HTTP link is being set.  All of the navigation anchor tags appear to be relative URLs.

Thank you.

0 Kudos
1 Solution

Accepted Solutions
PaulDavidson1
Regular Contributor

What happens when you put Portal into "Allow access to the portal through HTTPS only."

I believe without that setting, most pages that do not require HTTPS (such as login) will redirect to HTTP.

Perhaps the following will spark an idea:

I have had an issue with a problem that is sort of the reverse of this.

I was in Allow HTTPS only mode and turned it off.

Portal then would redirect to HTTP for most of the web pages but I kept getting an error that HTTPS was required.

In that situation, my IIS SSL settings were set to SSL Required.  I turned it off and was back to a mixed mode Portal that worked as expected.

View solution in original post

4 Replies
PaulDavidson1
Regular Contributor

What happens when you put Portal into "Allow access to the portal through HTTPS only."

I believe without that setting, most pages that do not require HTTPS (such as login) will redirect to HTTP.

Perhaps the following will spark an idea:

I have had an issue with a problem that is sort of the reverse of this.

I was in Allow HTTPS only mode and turned it off.

Portal then would redirect to HTTP for most of the web pages but I kept getting an error that HTTPS was required.

In that situation, my IIS SSL settings were set to SSL Required.  I turned it off and was back to a mixed mode Portal that worked as expected.

View solution in original post

LucasScharenbroich
Occasional Contributor

Turns out there were two issues in play.  Forcing HTTPS Only in the Portal Settings page fixed the issue in Chrome and Firefox.

As for IE, there was a Group Policy in place that set it to run in IE 7 mode for intranet applications; switching to a more recent IE version via the Developer Tools make the issue go away in IE as well.  So, that looks to be an organizational configuration issue at its root.

Thank for the suggestion re "HTTPS Only".  I had not realized that other pages would redirect to HTTP if permitted; somewhat unorthodox behavior....

DonnyVelazquez
Occasional Contributor

So basically you can't use portal in mixed mode. Check off "Allow access to the portal through HTTPS only." worked for me too.

0 Kudos
LeeHarding
New Contributor III

Worked for me too.

As the documentation dictates https only, wondering why default install left this unchecked?

Quick search found this, thanks!

Ours is not to reason why... back to beta testing my new P ortal.