Store Credentials for AGOL service layer in Portal

561
6
06-03-2020 01:56 PM
WesStieringer
New Contributor

I have a layer that my credentials authorizes my organization to see and use that is published by another organization on AGOL. 

When the layer is added to the map in Portal, using the service URL from AGOL, there is a prompt to store the credentials. I enter and save them, and save the map in Portal.

However, every time I open or refresh the map and/or app, I must enter my credentials again. So, it appears that they are not stored. I have reentered them, re-added the layer, all to no avail.

Anyone know a fix to this? Thank you. 

Reply
0 Kudos
6 Replies
JeffSmith
Esri Contributor

Hi Wes,

In order to store credentials for a secured service, the service url needs to be added as an item under 'My Content'.  Assuming the Portal can access the url, you'll see the option to save the credentials.  This new item is what needs to be added to the map to avoid having to enter credentials when viewing it later on.  If you simply add the service to a map, it will prompt you to enter credentials but will not allow you to store them.

Jeff

Reply
0 Kudos
WesStieringer
New Contributor

Hi Jeff,

Thank you for the input. Still doesn't work however. 

1. Add Item

2. From Web

3. paste the service URL, and choose Type: ArcGIS Server web service

4. A message "A secure service was detected" and I enter the username and password that has access to the layer, and I choose "Store credentials with service item. Do not prompt for authentication"

5. The title is ok, and I assign it a tag. 

When I try and view in a map, or add to an existing map, I get the Error Box "The layer, (layer name), cannot be added to the map. 

I've scoured help articles, and everything points to using these steps, as you've stated, but nothing works. 

Could there be a setting on the layer that is blocking it?

I appreciate any help I can get. Thank you.

Reply
0 Kudos
JeffSmith
Esri Contributor

Hi Wes,

What release of Portal are you using?  A little over a year ago ArcGIS Online transitioned to use TLS 1.2 only for all HTTPS communication.   Included in this transition was also the requirement to use SNI (Server Name Indication).  Portal for ArcGIS releases 10.5.1 and later all support this.  Earlier releases don't though and one of the issues encountered is not being able to access a service with stored credentials from ArcGIS Online as you described.  The following article goes into more detail.

FAQ: How is ArcGIS Enterprise and its associated software components, ArcGIS Server and Portal for A... 

If you are using 10.5.1 or later, it would probably be best to open a support call to help you troubleshoot this further.

Jeff

Reply
0 Kudos
WesStieringer
New Contributor
We are using ArcGIS Portal vs. 10.7.1  on ArcGIS Server Enterprise Standard v.10.6.1.
 
Thank you for your help Jeff. I greatly appreciate it. I'll escalate to our I.T. dept for a ticket with ESRI. 
Reply
0 Kudos
ZahidMia
New Contributor II

I am having same issue for “Portal for ArcGIS 10.7.1” with “Web Server SSL Protocols: TLSv1.2”. However, it is bit different as below:

  1. I have AGOL without having any trusted ArcGIS Server associated with it.
  2. A partner organisation has shared a group (Group A in their AGOL) with my AGOL.
  3. I am adding a layer (Layer 1) form the shared group (Group A) into my AGOL storing my admin credential and shared in another group (Group B, a group in my AGOL). This group is used in a collaboration with my portal group (Group C).
  4. I can view the layer (Layer 1) in portal group (Group C) but opening this layer in portal asks for admin credentials, though credential is stored when added in my AGOL.

I appreciate your advice.

Thanks
Zahid

Reply
0 Kudos
JeffSmith
Esri Contributor

Hi Zahid,

That is expected behavior.  The option to store credentials when collaborating between Online and Portal does not exist when sharing a secured service.  If you want to store credentials for the service from the partner organization, the service url would need to be manually added to the Content page on your portal.

Reply
0 Kudos