Since Using ArcGIS Online Assistant, Web Maps Don't Always Update When Overwriting Web Layers

189
1
3 weeks ago
Labels (3)
NicolasLapointe
New Contributor

I have been developping several Web Apps since last Fall for my company. During the development phase, the Portal acted normally. I would export a Web Map or a Web Layer from ArcGIS Pro, create an App from a Web Map and tweak several details (like definition querries, visibility ranges, symbology) from ArcGIS by overwriting Web Layers. The changes I did this way always updated the Web Maps automatically.

However, the last process I needed to do was to divide my Web Apps in different operational sectors. That meant one Web Map and one Web App for every sector, all copied from the original. I also had to apply different filters for every new Web Map so that it only displayed the data from the sector in question. In other words, I now have 20 Web Maps (and Web Apps) that depend from the same Server, but each having slightly different filters.

Creating all those Web Maps being a big job, I used ArcGIS Online Assistant to bring about all the changes quickly.

Unfortunately, since I did so, the Web Maps don't always update when I overwrite Web Layers from ArcGIS Pro. The visibility range is one of the elements that don't seem to update, but the symbology updates without any problem.

With that not working, I have to manually change every Web Map with the Online Assistant, which can be annoying.

Has anybody faced a similar problem? Is there an explication for this? I know that the Online Assistant wasn't developped by ESRI so I suspect some compatibility errors.

0 Kudos
1 Reply
jcarlson
MVP Regular Contributor

It's important to note that when you publish or overwrite a layer, what you're doing is setting the default symbology, labeling, scale range, etc. These are the settings visible in an item's Visualization tab in the Portal. Once a layer is brought into a map, however, those same settings can be overridden specific to that map.

If the map is updating to the new defaults (which I have seen happen), it's seems to be because the web map has no other settings of its own for the layer. But if I adjust any settings in the map, these take precedent over the layer's defaults, and future overwrites won't impact them anymore.

It sounds as if the web maps have a non-default visibility range stored. Thankfully, there is a simple way to deal with this. In AGO Assisstant, go to the web map's JSON and look for the minScale/maxScale items in the operational layers.

jcarlson_1-1619096852431.png

Delete those lines. That's it! Really!

Here's an example: I have a web map with a voting precincts layer in it, and I have a custom visibility scale defined (the image above). The layer itself has its own separate visibility range default. On the web map JSON, I deleted the min/max scale properties.

Rather than having no visibility scale, the layer reverts to the default setting. Here's an app that references the app. Despite no visibility scale being defined in the web map's JSON, you can see that at a certain scale, the precincts layer is no longer visible.

jcarlson_2-1619097085983.png

 

- Josh Carlson
Kendall County GIS
0 Kudos