"Scene Service is missing root node" errors

464
4
Jump to solution
01-14-2020 10:10 AM
Esri Contributor

We’re trying to publish scenes and  we have not been able to get past this “root node” error. Here is what I’ve tried.

 

  • Recaching all layers in the scene
  • Having enable SSL 3.0 in IE on the server (Suggestion from a GoeNet post)
  • Validating hosting server for the portal and all data stores in ArcGIS manager – everything validates
  • Checking permissions for the arcgis user in the datastore directory – looks good.
  • Adding a new file datastore to verify connections and permissions – successful
  • Recaching all layers again – caching succeeds, but the scene will not draw.  Still get the “root node” error for all scene layers.
Tags (1)
Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Contributor

Workaround

----------------------------------------------------------------------

How do I run Internet Explorer as a different user in Windows

To run an app as a different user in Windows 10, do the following.

Open File Explorer and go to the folder which contains the required app.

Press and hold the Shift key and right-click on the file.

In the context menu, select Run as different user.

Enter the new credentials and click OK to run the app.

----------------------------------------------------------------------

1. Open Internet Explorer as the “arcgis” local user

Press and hold shift key and right-click IE shortcut\

2. Internet Explorer > Internet Options > Security > Sites

     Disabled the option to Require server verification (https:) for all sites in this zone
      Added the 
http://mysite.domain.com  URL for ArcGIS Server   ( HTTP )

      Added the https://mysite.domain.com  URL for ArcGIS Server  ( HTTPS )

           Added the http://177.37.7.137  URL for ArcGIS Server ( HTTP )

                  ec2 instance Private IP – see the output of the command describedatastore.bat tile cache machines property, it uses the private IP)   <==  THIS SOLVED THE PROBLEM!!!!  

          Added the https://177.37.7.137  URL for ArcGIS Server ( HTTPS )

3. Internet Explorer > Internet Options > Advanced tab

        Use TLS 1.2 was already enabled

              Use SSL 3.0 was enabled

per suggestion on this forum article

https://community.esri.com/thread/194033-root-node-is-not-available-for-layer-open-published-scene

 4. Data Store Property

Connected to the Tools folder in “C:\Program Files\ArcGIS\DataStore\tools” and ran describedatastore
Ran changedbproperties --store tileCache --enablessl admin,data >> Operation completed successfully

changedbproperties:
https://enterprise.arcgis.com/en/data-store/latest/install/windows/data-store-utility-reference.htm#...

 

enablessl: This parameter controls use of the Transport Layer Security (TLS) protocol when populating the tile cache data store.

Supported options for the enablessl parameter are as follows:

  • admin: This is the default option. Specify admin to use Transport Layer Security when creating the container for the tile cache data store.
  • data: Specify data to use Transport Layer Security when writing scene layer data to the tile cache data store.
  • admin,data: Specify admin,data to use Transport Layer Security when creating and writing data to the tile cache data store.
  • none: Specify none to use HTTP communication from the hosting server when creating and writing to the tile cache data store.

5. Reboot the ec2 instance

View solution in original post

Reply
0 Kudos
4 Replies
Esri Contributor

Workaround

----------------------------------------------------------------------

How do I run Internet Explorer as a different user in Windows

To run an app as a different user in Windows 10, do the following.

Open File Explorer and go to the folder which contains the required app.

Press and hold the Shift key and right-click on the file.

In the context menu, select Run as different user.

Enter the new credentials and click OK to run the app.

----------------------------------------------------------------------

1. Open Internet Explorer as the “arcgis” local user

Press and hold shift key and right-click IE shortcut\

2. Internet Explorer > Internet Options > Security > Sites

     Disabled the option to Require server verification (https:) for all sites in this zone
      Added the 
http://mysite.domain.com  URL for ArcGIS Server   ( HTTP )

      Added the https://mysite.domain.com  URL for ArcGIS Server  ( HTTPS )

           Added the http://177.37.7.137  URL for ArcGIS Server ( HTTP )

                  ec2 instance Private IP – see the output of the command describedatastore.bat tile cache machines property, it uses the private IP)   <==  THIS SOLVED THE PROBLEM!!!!  

          Added the https://177.37.7.137  URL for ArcGIS Server ( HTTPS )

3. Internet Explorer > Internet Options > Advanced tab

        Use TLS 1.2 was already enabled

              Use SSL 3.0 was enabled

per suggestion on this forum article

https://community.esri.com/thread/194033-root-node-is-not-available-for-layer-open-published-scene

 4. Data Store Property

Connected to the Tools folder in “C:\Program Files\ArcGIS\DataStore\tools” and ran describedatastore
Ran changedbproperties --store tileCache --enablessl admin,data >> Operation completed successfully

changedbproperties:
https://enterprise.arcgis.com/en/data-store/latest/install/windows/data-store-utility-reference.htm#...

 

enablessl: This parameter controls use of the Transport Layer Security (TLS) protocol when populating the tile cache data store.

Supported options for the enablessl parameter are as follows:

  • admin: This is the default option. Specify admin to use Transport Layer Security when creating the container for the tile cache data store.
  • data: Specify data to use Transport Layer Security when writing scene layer data to the tile cache data store.
  • admin,data: Specify admin,data to use Transport Layer Security when creating and writing data to the tile cache data store.
  • none: Specify none to use HTTP communication from the hosting server when creating and writing to the tile cache data store.

5. Reboot the ec2 instance

View solution in original post

Reply
0 Kudos
Esri Contributor

AWS EC2 Multi Machine Deployment - Workaround Details

 

  • Portal+Server is in one ec2 instance and the Data Store (Relational & TileCache) is in another ec2 instance.
  • For each ec2 instance make the same Internet Explorer changes logged as the local user “arcgis”, then reboot the ec2 instances.
  • For each ec2 instance the Internet Explorer Trusted Sites has the HTTP &  HTTPS URLs with the Private IP of each ec2 instance ( see below for details ).
  1. Open Internet Explorer as the “arcgis” local user

Press and hold shift key and right-click IE shortcut. Run as Different User…

This did not work. I was able to open IE but the IE Trusted Sites changes did not persisted.

Workaround:

granted "remote desktop user" role to the local “arcgis” user then logged in and verified IE settings.

re-applied the settings

logged off/in, opened IE and settings were fine now

revoked “remote desktop user” from local “arcgis” user

  1. Internet Explorer > Internet Options > Security > Sites

disabled the option to Require server verification (https:) for all sites in this zone

add  these HTTP URLs

   http://agi-dev-3.esri.com

   < ec2 instances Private IPs >

   http://172.31.17.247          ags-dev-portal-3                                  

   http://172.31.17.87            ags-dev-data-store-3

   http://172.31.17.247          ags-dev-data-store-spatial-3

add  these HTTPS URLs

   https://agi-dev-3.esri.com

   < ec2 instances Private IPs >

   https://172.31.17.247          ags-dev-portal-3                                  

   https://172.31.17.87            ags-dev-data-store-3

   https://172.31.17.247          ags-dev-data-store-spatial-3

  1. Internet Explorer > Internet Options > Advanced tab

Use TLS 1.2 was already enabled

Use SSL 3.0 was enabled                        

  1. Data Store Property

ags-dev-data-store-3 – Data Store ( Relational & TileCache)

Connected to the Tools folder in “C:\Program Files\ArcGIS\DataStore\tools” and ran describedatastore

Ran changedbproperties --store tileCache --enablessl admin,data >> Operation completed successfully

changedbproperties:

https://enterprise.arcgis.com/en/data-store/latest/install/windows/data-store-utility-reference.htm#...

enablessl: This parameter controls use of the Transport Layer Security (TLS) protocol when populating the tile cache data store.

Supported options for the enablessl parameter are as follows:

  • admin: This is the default option. Specify admin to use Transport Layer Security when creating the container for the tile cache data store.
  • data: Specify data to use Transport Layer Security when writing scene layer data to the tile cache data store.
  • admin,data: Specify admin,data to use Transport Layer Security when creating and writing data to the tile cache data store.
  • none: Specify none to use HTTP communication from the hosting server when creating and writing to the tile cache data store.

               

Reply
0 Kudos
Esri Contributor

Question:

I am able to publish the scene service but I’m having issues with some textures being dropped. I don’t think it’s a problem related to this issue but I’m still troubleshooting. Any ideas by chance?

Answer: 

Disregard, just needed to rebuild the cache. Everything appears to be working as normal now.

Reply
0 Kudos
Esri Contributor

FYI for the future:
If you are using 10.7.1 or above software then you don’t need to run steps 3 and 4.
They are fixed in the software and will be of no use to set it up.
With 10.8 all we know is to perform step 2 on some OS and in cloud solutions where the security level is higher and therefore we need to add the machines as trusted sites.
This is not Esri software issue but the OS security level issue.

Reply
0 Kudos