Portal template app url

3125
5
11-30-2015 02:34 PM
DaveHighness
Occasional Contributor II

We have portal setup at a URL similar to the following "http://<portal url>/arcgis/home" through a reverse proxy. The WebContextURL parameter is set to "https:\\<portal url>/arcgis". Almost everything is working as it should. The only problem we are having now is when we try to create a an App using a template. The app creates fine but the resulting registered url is wrong. The URL ends up being something like this "http://<portal url>/app/..." which returns a 404 when you try to go to it. If you change it to this "http://<portal url>/arcgis/app/..." then the app loads. Why isn't it doing this from the get go? Can I change this behavior some where? I haven't found a spot to change this.

Thanks

Reply
0 Kudos
5 Replies
JeffSmith
Esri Contributor

This is a known issue in 10.3.1 Portal and will be fixed in 10.4.  There are two ways I can think of to work around it. 

1. If you create the app through Map Viewer instead of My Content, the url for the resulting app will be accurate.

2. You can use the ArcGIS Online Assistant to update the url for an app that has already been created to include the missing "/arcgis/".

DaveHighness
Occasional Contributor II

Jeff, thanks. Good to know. We had figured out that we could edit the URL for the app in Portal.

Reply
0 Kudos
GregAnspach
New Contributor II

We are having a similar problem in Portal where we have created an app using the Web App Builder and for some reason it will not use https.  Only http.  We have tried editing the URL properties of the application within Portal and also tried using the ArcGIS Online Assistant.  It is says it saved, it immediately goes back to http.

Any ideas?

Thanks!

Reply
0 Kudos
JeffSmith
Esri Contributor

Greg, the behavior you are seeing is expected.  The web application protocol is intended to change based on your Portal's SSL configuration setting.  This means if you do not enable SSL only, the web app can be accessed over http or https (and it defaults to http).  If you enable SSL only, it will only be accessible over https. 

If you want to change the url to be https, you need to edit another part of the url as well.  For example, when you edit the url, change it to https and add an extra '/' between webappviewer and index.html.  Once it is saved, you can edit it again and remove that extra '/'.  This will keep your https change.

Reply
0 Kudos
GregAnspach
New Contributor II

Thanks Jeff.  That worked!

I guess I am confused as to why it wants to default to http in our case.  Our portal is set to only allow SSL and the web site requires SSL.  Trying to access the anything without https will give you a 403.

Reply
0 Kudos