Portal login returns machine name

523
7
07-17-2018 09:13 AM
Highlighted
New Contributor II

I am running Portal for ARCGIS 10.6 on a federated, hosting server.  For some reason when I log into the portal, the domain name in the url changes to the machine name and cannot find the page. Once I repair the url back to the domain name, the login goes through and the home page comes up.  How can I fix the url re-direct, so it does not pick up the machine name?

Tags (1)
Reply
0 Kudos
7 Replies
Highlighted
Esri Frequent Contributor

Are you using the web adaptor or your own reverse proxy, like Apache or Nginx?

Reply
0 Kudos
Highlighted
New Contributor II

We are using the webadaptor.

I type in: https://domain name/webadaptor name

When it comes up, I sign in, and it tries to direct me to https://machine name/webadaptor name

This gives me an error. I fix the url back to //domain name/webadaptor name and it goes through to the portal organization page.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

If you were to sign into the Portaladmin API and go to System > Web Adaptors > WebAdaptor ID, does the URL listed there match the URL you're using to reach the Portal?

I'm assuming it doesn't. The URL you use to reach the Web Adaptor registration page is the URL that is set for the Portal, so if you have an alias on the machine, it may pick up the wrong one depending on the URL you use. Append /edit to the URL and then update the Web Adaptor URL to point to the correct URL if it's incorrect.

Reply
0 Kudos
Highlighted
New Contributor II

It doesn’t match. It is picking up the machine name in the URL.

I don’t see an option to Append/edit this URL here. I only see “Unregister Web Adaptor”.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor
Reply
0 Kudos
Highlighted
New Contributor II

That worked! Sneaky little tricks!

Thank you.

Reply
0 Kudos
Highlighted
Occasional Contributor III

I've had an issue similar to this, except the URL would change to the machine name only under certain circumstances. The solution we found was to modify the web context URL as shown here.

Configure your portal to use a reverse proxy server—Portal for ArcGIS (10.6) | ArcGIS Enterprise 

Reply
0 Kudos