Portal for ArcGIS editable Feature Service issue

135
2
09-24-2020 01:13 AM
VincentLaunstorfer
Occasional Contributor III

*** I reposted here, as a seperate question, the issue I am facing as I replied on a question marked as "Assumed Answered" and it is unlikely I will get any response

Hi, I have the same workflow and similar issues as posted ArcGIS Portal Editable Feature Service access issue 

 

My point feature service is published (I am the owner) with 'Add, update and delete feature' in the configuration tab when publishing from ArcGIS Pro (2.6.1), the feature service is linked to an enterprise GDB which is registered to the data store and the Portal (10.7.1) is federated. I have a Publisher role and the table is registered in the Enterprise GDB.

 

In a new WebMap on Portal for ArcGIS, once on the Edit tab, I only get 'Feature creation is disabled for all layers.' in the table of content. Although my layer should be editable. I can only Update attributes and Delete features. But I cannot Move or Create features... In addition, the Feature Service item details page do show:

Capabilities: Query,Create,Update,Delete,Uploads,Editing

 

Is there any setting/parameter missing?

 

For info: in ArcGIS Pro, I can Add, Update and Delete feature from the same point layer stored in Enterprise GDB. And any changes appear in the WebMap.

Reply
0 Kudos
2 Replies
ZachBodenner
New Contributor II

I am having this exact same issue. It's very strange because I've gone through this workflow dozens and dozens of times. For some reason my attempt to publish a new feature service with all the same configurations that I always used is somehow not working. I've deleted the service and republished it to no avail. Published both through Map and Pro. Anyone have any ideas?

Reply
0 Kudos
ZachBodenner
New Contributor II

Hey just wanted to let you know that I solved me issue, and maybe you might have done the same thing. So I had created a new feature class in catalog that I would up publishing. Only, I space-cased it and forgot to change the coordinate system of the new feature class. I wound up creating it in Web Mercator, but the basemap in my web map (and app) that I was trying to do the editing in was in our local county system. After re-creating the feature class in the appropriate system (or I suppose projecting would work too) and republishing the service I can edit again. You didn't mention your CS in your troubleshooting workflow so maybe that's it?

Reply
0 Kudos