No Enable Attachment Option

168
4
04-05-2021 07:48 AM
JasonCyphers
Occasional Contributor

I have a feature with related table stored in our GIS database, that is published to our GIS Portal as a Feature Service.

I need to enable attachments on the table, that is used for inspections; however, I do not have that option from the data page of the Feature Service:

JasonCyphers_0-1617633772950.png

Looking at the rest directory information about the table, the line Has Attachments is true, and attachments are enabled on the table in the server; however, when trying to create a Survey123 form with the feature, I get an error when trying to publish the survey that Enable Attachments must be true.

Any ideas on how to enable attachments on the table?

 

0 Kudos
4 Replies
JayantaPoddar
MVP Honored Contributor

Enable Attachment option in Portal is available for the hosted feature layers. A similar post How do we get the "Enable Attachments" button to show up on our portal feature layer? 

What happens if you use Feature Service Layer (ArcGIS REST URL) for creating Survey123 form?

0 Kudos
JasonCyphers
Occasional Contributor

We may have to dig a little deeper then, because the table has attachments enabled on the server; however, Portal doesn't seem to be picking that up since Survey123 is giving me an error saying attachments aren't enabled.

0 Kudos
JayantaPoddar
MVP Honored Contributor

The reason is because the layer is not a hosted feature layer (hosted in Portal), but an ArcGIS Server Feature Layer (published to ArcGIS Server through registered data source). In Portal, you will get the option for enabling attachments in hosted feature layers only.

See the differences in Feature Layers 

However the corresponding Feature Service (ArcGIS Server) may be directly used in Survey123 form creation.

Alternatively, you may publish hosted feature layer to Portal.

0 Kudos
RobertBorchert
Frequent Contributor II

Turn off all services that may be using that table. Enable GlobalID for all tables and features involved. Make sure the table is not participating in an edit session.  Then try it.

0 Kudos