New error 00334 when publishing with ArcGIS Pro 2.6.1 with custom arcade expression on symbology

437
8
Jump to solution
09-17-2020 06:15 AM
New Contributor III

I have a layer with a custom expression of nested arcade If statements. This expression worked prior to updating ArcGIS Pro to 2.6.1 and still works in Pro itself now. However, where before I had no issue with publishing the layer to Portal, now I receive an Error 00334 stating that the symbology is referencing a subtype and the values must be included in the subtype field to enable feature access.

This wasn't an issue in the version prior to 2.6 (2.5.X?) but is now. I'm assuming its a bug but am hoping there's a work around.

Additionally, another layer on the same map does NOT show any errors when publishing. However, when published it is not on the feature layer. It is present on the published map image layer, but not the feature layer. It does have errors on ArcGIS Server Manager, however. On manager, the layer states that there was an error while initializing types for the layer. It states "Error while initializing Type for unique value: 10 label: Vent Valve for layer: Name of Layer." And it has multiple of those, replacing Vent Valve with each other label on the layer.

Does anyone have suggestions for fixing these issues?

1 Solution

Accepted Solutions
New Contributor II

I just got news that Esri have created three new BUGs during the last month related to this very issue (BUG-000133656, BUG-000133942 and BUG-000134075). I guess we can expect this will be solved relatively soon.

View solution in original post

8 Replies
Esri Contributor

Hi Robert,

Does the solution in the analyzer error topic help? 00334

Jonah

Reply
0 Kudos
New Contributor III

Hello Jonah,

Unfortunately, it does not. The symbology uses a custom arcade expression (which published with no errors in Pro 2.5 and still has a feature layer referencing the existing published service). The expression takes values from two fields and creates a third, non-field based field upon which the symbology is then based.

The code looks like a longer version of this:

var size = $feature.PIPEDIAMETERDBL;

var pressure = $feature.OPERATINGPRESSURE;

 

var result = 'Unknown';

if (pressure == 'LP') {

    if (size < 😎 {

        result = 'Low Pressure, Under 8"';

    } else if (size <= 12) {

        result = 'Low Pressure, 8-12"';

    } else {

        result = 'Low Pressure, 14"+';

    }

Thus, the end result is values like "Low Pressure, 14"+" in the symbology list.

Reply
0 Kudos
New Contributor II

Are you sure the error is caused by the Arcade expression?
We have a similar situation here after upgrading Pro from 2.5 to 2.6.1. In our case, we have a project containing feature classes with subtypes, but no Arcade expressions. We are trying to overwrite an ArcGIS Map/Feature Service, but the process is blocked by the same 00334 error.

If we open the same project in ArcGIS Pro 2.5, overwriting the service works just fine.

New Contributor III

There are other features with subtypes on the layer that aren't giving the same error, so I don't think so. I'm not 100% positive though.

Reply
0 Kudos
New Contributor II

I also have a similar problem to Robert. I have a custom arcade expression on a feature class that has subtypes. Prior uppgrading to 2.6.0 I could publish my service without any problems. Now I get the 00334 error.

Any suggestions to this problem from ESRI?

New Contributor III

I am having a similar problem.  I don't get the 00334 error but my subtypes are NOT working when published from 2.6.0. They were working at 2.4.1.

Reply
0 Kudos
New Contributor II

I just got news that Esri have created three new BUGs during the last month related to this very issue (BUG-000133656, BUG-000133942 and BUG-000134075). I guess we can expect this will be solved relatively soon.

View solution in original post

New Contributor III

Hello Martin,

Are there ESRI support articles on those bugs? I couldn't locate them on the support page.

Reply
0 Kudos