Invalid redirect when logging into Portal for ArcGIS

1666
3
11-10-2017 03:47 AM
Highlighted
New Contributor III

I installed the following esri products:

  1. ArcGIS Server 10.5
  2. Web Adapter for ArcGIS Server 10.5 
  3. Portal for ArcGIS 10.5
  4. WebAdaptator for ArcGIS server 10.5
  5. ArcGIS Data Store 10.5

I activated a domain certificate which I attached port 443.

However, I only have access to ArcGIS portal locally

but using https://domaine.com/arcgis/home a redirection url is asked 


In addition I can not change the URL of the webdaptator as indicated in the following discussion: https://community.esri.com/thread/119888

Could you help me please?

Thank you

3 Replies
Highlighted
Esri Frequent Contributor

If you go to https://<machine>.<domain>.com:7443/arcgis/portaladmin/security/oauth/getAppInfo, and then enter arcgisonline for the App ID, do you see your FQDN listed there?  If not, take the returned JSON, add your FQDN to the array of redirectURIs, and then go to Update App Info resource and paste it in for the App Info parameter.

Highlighted
New Contributor III

Hello Jonathan

I added the FQDN to the array of redirectURIs,

Indeed, it works perfectly !!

Thank you very much for the help!

Reply
0 Kudos
Highlighted
New Contributor III

Try to set the webcontext parameter just like this link:

Using a reverse proxy server with ArcGIS Server—ArcGIS Server Administration (Linux) | ArcGIS Enterp... 

the link is for linux but works with Windows too. Just set the webcontext parameter using Admin interface.

Reply
0 Kudos