Invalid redirect_uri portal Error: 400 signin

2285
2
Jump to solution
10-16-2017 01:00 PM
BillHarvey1
New Contributor III

Hello,

I have seen some posts regarding this, but they all use a web adapter and there are no conclusive answers that I can find.  We are not using any web adapters because we are using a load balancer and there is no web tier authentication (ESRI approved design).

I install the first site and create the Portal.   Add the second site to the existing Portal and it registers fine.   I can see both machines in \portaladmin and their status is good.   I can login to the first machine in the site, but get a Invalid redirect_uri portal Error: 400 signin error when using the second machine.  For example:

https://machineONE.com:7443/arcgis/home/signin.html        Original machine created site.   Can login.

https://machineTWO.com:7443/arcgis/home/signin.html       Added to existing portal successfully.   CANNOT login, however I can login to /portaladmin.

Before I set up the load balancer both of these need to work.

Why the redirect error?

Thanks.

0 Kudos
1 Solution

Accepted Solutions
BillHarvey1
New Contributor III

I was just cleaning up some of my old threads.  This was as simple as re-booting of all the machines that participate in the site.   You know, like going to the Doctor with a cold and he stops and restarts your heart and you are cured.   🙂

View solution in original post

0 Kudos
2 Replies
JonathanQuinn
Esri Frequent Contributor

If you were to go to https://<machine1>:7443/arcgis/portaladmin/security/oauth/getAppInfo

and then set the App ID to "arcgisonline", do you see both machines listed under the redirectURI's? If not, take the JSON that's returned, and append machine2, then go to /arcgis/portaladmin/security/oauth/updateAppInfo and paste in the new JSON:

Ex.

Response from getAppInfo:

{"appId":"arcgisonline","redirectURIs":["https://machine1.domain.com"]}

add your other machine:

{"appId":"arcgisonline","redirectURIs":["https://machine1.domain.com","https://machine2.domain.com"]}

Take this new JSON and enter it in for the App Info parameter under updateAppInfo.

BillHarvey1
New Contributor III

I was just cleaning up some of my old threads.  This was as simple as re-booting of all the machines that participate in the site.   You know, like going to the Doctor with a cold and he stops and restarts your heart and you are cured.   🙂

View solution in original post

0 Kudos