Infinite redirect loop in IE 11 with Portal home page thru NLB in HA scenario

1083
2
01-16-2018 02:08 PM
IvanMekhedov
New Contributor

Hey everybody!

When trying to access Portal home page thru load balancer (http://loadbalancer.domain.com/webataptorname) in IE 11, the browser stucks in an infinite redirect loop:

https://loadbalancer.domain.com/webadaptorname/home -> https://loadbalancer.domain.com/webadaptorname/home -> etc.

The webcontexturl property is set both in Portal and Server properties : "webcontexturl" : "http://loadbalancer.domain.com/webataptorname" and "http://loadbalancer.domain.com/webataptorname_server" consequently.

Portal and Server are 10.4.1 versions and are federated.

When accessing Portal home page thru load balancer in other browsers (Chrome, Firefox, Safari), all works fine.

When accessing Portal home page thru web adaptor URL in IE 11 (http://webdataptor.domain.com/webataptorname), all works fine as well.

NLB redirects requests to two ArcGIS web Adaptors (IIS) is only used to overcome ArcGIS Web Adaptor possible failure.

Portal and Server also communicate thru the same NLB: its name was pointed when federating Portal and Server in Portal Organizational Settings page.

Any ideas?

0 Kudos
2 Replies
IvanMekhedov
New Contributor

This seems to be posted to TechSupport ...

0 Kudos
JonathanQuinn
Esri Frequent Contributor

At first glance, this seems like a problem in the LB, but if it works in other browsers, then it's not an LB problem.  What version of IE are you using, and is it in a compatability mode?

0 Kudos