IE 11 security prompt with SAML redirect for login - The webpage you are viewing is trying to close the tab.

06-13-2017 10:24 PM
New Contributor III

IE 11 security prompt with SAML redirect for login - The webpage you are viewing is trying to close the tab.

Hi there,

When using OKTA with Portal (as an IDP), when you click the Sign in with my enterprise login a new tab opens which redirects to the IDP. Once you sign in the IDP attempts to close the tab and redirect on the original tab which creates a popup that says:

The webpage you are viewing is trying to close the tab. Do you want to close this tab? Y / N

Clicking yes and you continue as normal. Apparently this is an IE security measure and isn't able to be disabled in IE 11 and is to do with javascript attempting to close a window from a host that did not initiate the window open. There are snippets of js to get around this but of course I don't want to have to go digging inside Portal to find the js to change. Note that Chrome and Firefox don't show this behaviour but IE is the customers corporate standard. Has anyone come across this or have a workaround, fix?



Annoying IE popup


Tags (2)
10 Replies
Esri Regular Contributor

Hi Fraser,

The easiest fix I've seen for this would be to add to your list of trusted sites in IE.


New Contributor III

Adding site to the trusted sites did not work for us.

0 Kudos
Esri Contributor

Same here, adding site to trusted sites does not work. Any other thoughts? Customers find this very annoying!

Esri Contributor

I had the similar issue and did the following to work in our organisation. Probably not the way to go and needs to be modified or tested whenever the Portal for ArcGIS is upgraded or with any browser updates

On top of the SAML pop-up (screenshot 1), up on selecting the ADFS option,  I do get one more additional IE pop-up in a new tab (screenshot 2) which can be closed after clicking on option “Yes” which in turn returns to parent window.




Currently, I made a change to the core Portal file to suppress the IE pop-up in the following path


Path: D:\Program Files\ArcGIS\Portal\webapps\arcgis#home\postsignin.html


Modification: Basically, code was already written in the file to suppress the pop-up, but the condition to enter into the code was incorrect. The existing condition in the code is, if (navigator.appName === "Microsoft Internet Explorer").

But, the navigator.appName reads as Netscape instead of IE acronym and failing to close the pop-up automatically. So, had to change the condition to verify the browser appName as “Netscape”, which did the work at the moment. 


Environment: Windows 10, IE11, Portal for ArcGIS 10.6 (It’s the same code in 10.6.1 as well)


Update/Solution: According to the Compatibility changes, IE 11 returns the word  “Netscape” for navigator.appName property, to reflect the HTML5 standards to match the behavior of other browsers.

New Contributor II

Thanks that worked for me!!

0 Kudos
Esri Frequent Contributor

Thanks for posting the workaround. I tested in-house and see the original behavior and that the workaround works. We'll get this sorted out in the software.

Esri Contributor

Hi Jonathan, this is great news! Just to be sure, did your testing include the major desktop browsers as well as the browsers on various mobile devices? If so you saved me time 🙂 Looking forward to see this change in future releases.

0 Kudos
Esri Contributor

We have internally tested for our Organisation project and everything seems to be working fine from the time it was modified. Hope to see the change in next releases soon.

0 Kudos
New Contributor III

Ravi Dhulipudi‌, Jonathan Quinn

I encounter the same issue with IE 11. We are on ArcGIS Portal 10.7.1.

It appears the workaround that is mentioned here was already implemented in this release. However still facing the same problem. Any suggestions or other workarounds to fix this?

C:\Program Files\ArcGIS\Portal\framework\webapps\arcgis#home\postsignin.html

0 Kudos