How Can I Fix The Missing Map Title in the Portal Print Widget?

271
2
01-10-2019 04:18 PM
Mark_Hotz
Occasional Contributor II

I have been working on a custom print widget template in ArcGIS Pro to use in Portal, and have finally managed to get it to work...except somewhere along the line the application lost the Map Title window.  When I open the print widget in a Portal web app the print widget window should display like this:

However, When I now open the print widget it's missing the Map Title window:

I'm not sure where to configure or fix this...my Portal config window looks like:

Does anyone have any suggestions on where I might have missed a step?  Everything else is working exactly how it should work...just this Map Title Window is missing, without which users won't be able to add a custom title to their map.

Thank you

Reply
0 Kudos
2 Replies
VickyShort
Occasional Contributor

Hi

I had this exact same problem. I worked out that the Title in ArcPro should be 

<dyn type="layout" property="metadata" attribute="title"/>. Once I had corrected my templates and republished the service it worked. 

I hope this helps.

Reply
0 Kudos
Mark_Hotz
Occasional Contributor II

Vicky:

Thanks for the help.  I had made a dozen of these templates and for the life of me I could not figure out why this one template was missing the title in Portal.  But your suggestion is exactly what it was...I was missing the title code in that one dynamic text box.  It's strange how we can sometimes miss the obvious, even when it's right there in front of us .

Thanks again.

Reply
0 Kudos