Hiding items from the Gallery in the Portal (for ArcGIS 10.3.1)

2877
2
Jump to solution
11-19-2015 05:02 AM
SvivaManager
Occasional Contributor II

Hello,

We have a federated Portal for ArcGIS 10.3.1 and many different map and geometric services published on the server which all shows at the gallery. Obviously they all need an anonymous  permission to work but the problem is, every user that see the Gallery at the portal, can see and access those services.. Anyone knows a way to hide items completely from the gallery and yet, make sure they have full anonymous permissions? (while still staying a federated server of course)

Is there a way to hide the Gallery completely? I think this should be even more simple to do..

0 Kudos
1 Solution

Accepted Solutions
DerekLaw
Community Moderator

Hi Sviva,

> Anyone knows a way to hide items completely from the gallery and yet, make sure they have full anonymous permissions?

This is not possible, because Portal items shared with 'everyone' (i.e., enabling anonymous access) cannot be hidden. This is by design. If you want to restrict access for certain Portal items, then you should leverage the named user accounts in Portal.

> Is there a way to hide the Gallery completely?

A simple workaround is to create a new Portal group, status to 'public' and contains no items. Then simply select this group for the 'show in gallery' option for the Gallery property of your Portal. Now the Gallery page will appear blank and "hidden".

Hope this helps,

View solution in original post

2 Replies
DerekLaw
Community Moderator

Hi Sviva,

> Anyone knows a way to hide items completely from the gallery and yet, make sure they have full anonymous permissions?

This is not possible, because Portal items shared with 'everyone' (i.e., enabling anonymous access) cannot be hidden. This is by design. If you want to restrict access for certain Portal items, then you should leverage the named user accounts in Portal.

> Is there a way to hide the Gallery completely?

A simple workaround is to create a new Portal group, status to 'public' and contains no items. Then simply select this group for the 'show in gallery' option for the Gallery property of your Portal. Now the Gallery page will appear blank and "hidden".

Hope this helps,

View solution in original post

SvivaManager
Occasional Contributor II

Thanks Derek, interesting workaround, I'll check it out.

0 Kudos