help configuring Portal 10.3 on Amazon EC2

3955
3
02-02-2015 10:20 PM
MichaelKaminski
New Contributor

Hi out there,

 

I'm hoping that someone out there will be able to help us.

 

We are trying to deploy Portal for ArcGIS on Amazon EC2. We have installed Portal and the WebAdapter. I have tried following the steps on the resources pages but am having issues when trying to get to the page to create the initial logon.

 

If i connect to https://localhost/{sitename}/home, i get a "This page cant be displayed" when i run the fix connection problems tool it comes up with "the remote device or resource wont accept the connection"

Any idea would be greatly appreciated.

Tags (1)
0 Kudos
3 Replies
JayantaPoddar
MVP Esteemed Contributor

Hi,

Did you try enabling SSL to your web server.

ArcGIS Help (10.2, 10.2.1, and 10.2.2)

Also check if the given port (e.g. 443) is allowed through the firewall.

Thanks,

Jay

0 Kudos
MichaelKaminski
New Contributor

Hi,

Yes, i created a self signed certificate and bound it to port 443 and enabled the inbound TCP rules for Portal on ports outlined in the ESRI doco.

I did an IIS restart via cmd and now when i hit the https://localhost/{sitename}/home i get to the webadapter homepage but with the messgae "No Portal in configured" with no option to login or configure anything?

thanks

GEM

0 Kudos
AlexanderJarvo
New Contributor II

Not sure if you're still having this issue but according to documentation, you must use a CA signed certificate to run portal on Amazon. It cannot be self-signed.

Deploy Portal for ArcGIS on AWS—Portal for ArcGIS (10.3 and 10.3.1) | ArcGIS for Server

0 Kudos