ESRI Maps for Office - unable to share maps from Excel to Portal

3999
7
05-12-2015 07:14 AM
AllenGuan1
New Contributor II

I have a few rows in an excel file with point XY locations.  I used the ESRI maps
plugin to add those locations to a map inside excel. The map look good. But when I tried to share either the map or the excel layer, the sharing seems to hang. Is there anything I need to do to make this work? I have ArcGIS 10.3/Portal 10.3 federated with data store behind them. It is Integrated Windows Authentication.

Tags (1)
0 Kudos
7 Replies
DerekLaw
Community Moderator

Hi Allen,

Have you installed the Esri Maps for Office Resources for Portal for ArcGIS 10.3 or higher resource files? The Portal resource files must be installed on same machine as your Portal machine.

Learn more here: Working with Portal—Esri Maps for Office | ArcGIS

Hope this helps,

0 Kudos
AllenGuan1
New Contributor II

Derek,

Thanks for reply. Yes I did install the ESRI Maps for Office Resources for ArcGIS 10.3 on the portal server. But the problem persists. I have had an ESRI consultant working with me on this for more than 2 weeks, but could not identify the issue.

Allen

0 Kudos
DerekLaw
Community Moderator

Hi Allen,

When you say "had an ESRI consultant working with me", do you mean you've opened an Esri Tech Support incident and are still working on this issue?

Some additional questions:

- What version of Esri Maps for Office are you using?

- What version of MS Excel are you using (2010 or 2013)?

- What Windows OS?

- What version of IE are you using?

- Would it be possible to get a Fiddler log when you attempt to share the data from Excel to Portal for ArcGIS?

Thanks,

0 Kudos
AllenGuan1
New Contributor II

Derek,


Our Portal was set up by an ESRI consultant under EEAP. This problem of not being able to share EXCEL map/layers to Portal has been bugging us for a few weeks. Here are the answers to your quesitons:

- Esri Maps for Office 3.0 (32 bit)

- 2010 Excel (32 bit)

- Windows 7 (64 bit)

- IE 9.08112.16421

- Attached is the Fiddler log when clicking the "share" on ESRI map. #2,3,4 are the results showing when I click “share” for layer. Then nothing more shows up within 10 minutes, and the sharing is
hanging. Click on any one of them does not show any detail.



 


0 Kudos
DerekLaw
Community Moderator

Hi Allen,

Unfortunately, the Fiddler log is not too helpful as all the requests are encrypted. Is it possible to enable decryption on fiddler requests so that we can get more details. Also can you please save the fiddler session as .saz format?

Thanks,

0 Kudos
DerekLaw
Community Moderator

Hi Allen,

From the Esri Maps for Office Dev team:

Yes this was a known issue in 3.0 release. We have fixed this in the upcoming 3.1 M4O version. To summarize this issue is specific to following environment [IE9 + M4O + Portal]

Easy workaround is for the client machines to have IE10 or IE11 browser.”

Hope this helps,

0 Kudos
AllenGuan1
New Contributor II

Derek,

Thanks for the update. I will get a machine with IE11 (our targeted upgrade) and see how it works.

Allen