Error Adding Locator in Portal for ArcGIS

1027
9
Jump to solution
09-04-2018 03:42 PM
PawelGanczarski
New Contributor III

Hello,

I've come across an error while attempting to add a geocode locator in Portal for ArcGIS 10.6. 

I want to use the geocoding locator utility service available on a federated ArcGIS Server 10.6

Followed the instructions in the documentation http://enterprise.arcgis.com/en/portal/latest/administer/windows/configure-services.htm#ESRI_SECTION...

but when pasting the URL copied from the service overview page in Add Locator in Edit Settings, error messega indicates the URL is invalid. See screenshot below.  The geocoding service is started and shared with the organization.

Any help will be appreciated,

Best regards,

Pawel

0 Kudos
1 Solution

Accepted Solutions
MarleyGeddes
Esri Contributor

Hi Pawel, 

I understand the documentation on this subject is confusing.

The GeocodingTools is the geoprocessing service that runs in the background and supports the ability to batch geocode. It is not the actual geode service or locator service that is used to match addresses during geocoding.

By default, you have the ArcGIS World Geocoding Service available. However, this does not support batch geocoding. To batch geocode, you will need to (1) enable the ArcGIS World Geocoding Service for batch geocoding, or (2) publish your own locator service and set that as your organizations geocode utility service.

(1) To enable the ArcGIS World Geocoding Service for batch geocoding, you will need to enable Geocoding under the ArcGIS Online tab of your Organization settings. This will require you enter ArcGIS Online account credentials. Note that using the Online batch geocoder will cost credits.

(2) To publish your own locator service, follow the instructions from the following topics (from pro and arcmap):

Publish a locator to your portal—ArcGIS Pro | ArcGIS Desktop 

Publishing a geocode service—Help | ArcGIS Desktop 

Make sure to publish the locator with batch geocoding enabled to have that capability in Portal.

Once the Locator Service item in Portal, ensure it is shared to your organization. Then you should be able to add the Locator as a geocoding utility service under the Utilities Services tab under the organization settings. If you have issues with this step, try the steps outlined in my first comment.

Hope this helps,
Marley

View solution in original post

9 Replies
MarleyGeddes
Esri Contributor

Hi Pawel, 

First, is the federated ArcGIS Server also the Hosting Server?

If so, on the 'Add Locator' dialog, can you try selecting 'From Existing Locator' and see if the locator is listed in the Locator Item drop-down. If it is, try adding the locator using this method.

Another suggestion is to add the locator to your portal as an item from the web.

1. Navigate to the Content page

2. Select Add Item > From the Web

3. selecting 'ArcGIS Server web service'.

4. Paste the REST URL of the locator service under the URL parameter.

5. Enter you credentials under the 'a secure service was detected' section

6. Select the 'Store credentials with service item. Do not prompt for authentication"

7. Click 'Add Item'

8. Share the locator item with the Organization

9. Under the Utility Services tab of the Organization Settings click 'Add Locator'

10. Select 'from existing locator'

11. The locator you just added should show in the drop-down

Hope this helps,
Marley

0 Kudos
PawelGanczarski
New Contributor III

Hello Marley,

Thanks for your reply. 

Yes, the federated ArcGIS Server is also the Hosting Server.

The locator does not show in the drop down. The only one that shows is a temporary solution I'm using from a borrowed 

AGOL organisational account.

I followed the steps ( except number 6, the option in not available) you listed and the locator still won't show in the drop down list of existing locators.

Thanks,

Pawel

0 Kudos
MarleyGeddes
Esri Contributor

Hi Pawel, 

I have a few questions:

1. Can you confirm that the REST URL of your locator service is the following format:

https://<webadaptorhost>.<domain>.com/<webadaptorname>/rest/services/<servicename>/GeometryServer

2. When you add the item to portal, does it show as a 'Locator' item?

3. When you were adding the locator to your portal, did the 'a secure service was detected' section appear that allowed you to enter credentials (step #5) and just the option to store the credentials not appear (step #6)?

4. Does your portal trust your server certificate? See Configuring the portal to trust certificates from your certifying authority—Portal for ArcGIS (10.6)... 

Thanks,
Marley

0 Kudos
PawelGanczarski
New Contributor III

Hi Marley,

To answer your questions:

1. .../rest/services/Utilities/GeocodingTools/GPServer

2. It shows as "Geoprocessing Service"

3. Correct

4. I'm not 100 % sure how best to answer this, but I know that 2 security certificates had to be generated in order for the portal to work ( a couple of months ago). Below is the screen grab of the one linked with portal 

I hope this helps,

Thanks,

Pawel 

0 Kudos
MarleyGeddes
Esri Contributor

Hi Pawel,

The issue is because you are trying to add a Geoprocessing Service as your Geocoding Utility Service. You can only add a Locator Service (Geocode Service) as a Geocoding Utility Service in Portal.

The URL would follow the format (key is that it will end in /GeometryServer):
https://<webadaptorhost>.<domain>.com/<webadaptorname>/rest/services/<servicename>/GeometryServer

Here is some documentation on publishing a Locator / Geocode Service from Pro and ArcMap:
Publish a locator to your portal—ArcGIS Pro | ArcGIS Desktop 
Publishing a geocode service—Help | ArcGIS Desktop 

Thanks,
Marley

PawelGanczarski
New Contributor III

Many thanks Marley

0 Kudos
PawelGanczarski
New Contributor III

Just wanted to say that the reason I was trying to add it as a service is due to the esri documentation. 

So my question is, how can the Geocoding operation be enabled on that service ? 

Best regards, 

Pawel

0 Kudos
MarleyGeddes
Esri Contributor

Hi Pawel, 

I understand the documentation on this subject is confusing.

The GeocodingTools is the geoprocessing service that runs in the background and supports the ability to batch geocode. It is not the actual geode service or locator service that is used to match addresses during geocoding.

By default, you have the ArcGIS World Geocoding Service available. However, this does not support batch geocoding. To batch geocode, you will need to (1) enable the ArcGIS World Geocoding Service for batch geocoding, or (2) publish your own locator service and set that as your organizations geocode utility service.

(1) To enable the ArcGIS World Geocoding Service for batch geocoding, you will need to enable Geocoding under the ArcGIS Online tab of your Organization settings. This will require you enter ArcGIS Online account credentials. Note that using the Online batch geocoder will cost credits.

(2) To publish your own locator service, follow the instructions from the following topics (from pro and arcmap):

Publish a locator to your portal—ArcGIS Pro | ArcGIS Desktop 

Publishing a geocode service—Help | ArcGIS Desktop 

Make sure to publish the locator with batch geocoding enabled to have that capability in Portal.

Once the Locator Service item in Portal, ensure it is shared to your organization. Then you should be able to add the Locator as a geocoding utility service under the Utilities Services tab under the organization settings. If you have issues with this step, try the steps outlined in my first comment.

Hope this helps,
Marley

View solution in original post

PawelGanczarski
New Contributor III

Thanks for that Marley.

0 Kudos