ArcGIS Enterprise 10.7 / AWS / Load Balancer / Webadaptor

501
6
05-28-2019 12:43 PM
Highlighted
New Contributor

Hi there!

I have instaled ArcGIS Enterprise using AWS Ubuntu AIM, after install I just upgrade to 10.7 and register the server, datastore and portal.

For now I have two questions.

1. How I have to configure webadaptor in a Ubuntu configuration? This is the folder webadaptor content after the instalation. 

I have tryed the configurewebadaptor.sh in tools folder, but I am reall confuse about how to configure the webadaptor.

2. I can access using RDP to connect to my ubuntu server the portal site but only with this url

https://127.0.0.1:7443/arcgis/home

But the portal looks like incomplete.

Also, I have configured a load balancer and add my ArcGis server with 6443 and 7443 ports to my Target group. 

When I access to my load balancer dns using 6443 port works like a charm, however to port 7443, always redirect to 127.0.0.1, so it does not keep my dns, I asume this is because my webadaptor is not configured.

If any of you have suggestios, please let me know.

Thanks

Reply
0 Kudos
6 Replies
Highlighted
Esri Frequent Contributor

If you run configurewebadaptor.sh, it'll give you the command line arguments required to register it:

Once you register the web adaptor, if you have an ELB in front of the portal, set the Web Context URL.

Reply
0 Kudos
Highlighted
New Contributor

Hi Jonathan

I just try, but I receive this error

I have to tell you, this is my first experience installing this software. So, I do not know if I am using the corrects parameters.

Beside, how do you configure your Load Balancer in AWS? especially the ports

Thanks

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

The web adaptor URL should the local IP address or hostname. In AWS, it'll be the local IP as those machines don't have hostnames:

https://10.0.0.1/arcgis/webadaptor

I'd suggest you look into the CloudFormation templates so you don't have to configure the environments yourself:

https://enterprise.arcgis.com/en/server/latest/cloud/amazon/arcgis-server-architectures-on-aws.htm

Reply
0 Kudos
Highlighted
Occasional Contributor II

Adolfo,

Your ArcGIS Server URL in the screenshot has port 7443, which is the incorrect port.  ArcGIS Server uses port 6443.

-Danny

Reply
0 Kudos
Highlighted
New Contributor

Hi there.

I just ask for Esri support team to help us to set this configuration. 

I'll let you know how this ends

Thanks

Reply
0 Kudos
Highlighted
New Contributor III

Hello, 

With the help of Support, you guys have been able to solve this issue?

Thanks 

Reply
0 Kudos