AGOL to Portal Collaboration Question

140
2
09-28-2020 01:58 PM
Mary_EllenPerko__not_ncid_
Occasional Contributor

Hi.  We are looking into using our on-prem portal as a backup repository for some AGOL content.  While testing, we're running into an issue I'm unsure how to resolve.

When syncing hosted feature layers from AGOL to Portal that are larger than about 1 GB, the sync says it is successful, but the hosted feature layer does not exist in Portal.  It seems anything less than 1 GB in size works as expected.

I have been unable to find any error messages.  We've looked through server manager and the portal administrative directory. 

Does anyone have any ideas?  What might be going on?  Where error messages may be located?  I'd appreciate any assistance.

Thanks. 

Tags (1)
Reply
0 Kudos
2 Replies
KaitlynPurcell
Esri Contributor

Hi Mary Ellen Perko (not ncid)

According to documentation, if the workspace is set to copy data and the feature layer is > 1 GB, the receiving organization should see this layer shared as a reference, rather than a copy. If the sync was successful, I would expect to see a corresponding item in the receiving Org. I suggest we see if a manual synchronization gives any further information. 

Navigate to the portal/sharing/rest endpoint (https://<machine.domain>/<webadaptorname>/sharing/rest

  • Login at the top right
  • Select Org ID
  • Scroll to the bottom of this page and select Collaborations under Child Resources
  • Select the Collaboration Id
  • Select Collaboration Workspaces under Child Resources and select the correct Workspace Id
  • Under Supported Operations select Sync
  • Select the option to Sync Collaboration Workspace Asynchronously > Sync
    • You should see the Job Id and the Status Submitted
  • At the top of this screen, select the Workspace Id
  • Under Supported Operations select Sync Status
  • Select the corresponding status Id when the Status says completed to get more information about the job

If you need assistance completing this workflow or debugging any information found here, I'd encourage you to log a case with Technical Support.

Hope this helps!

Kaitlyn

Mary_EllenPerko__not_ncid_
Occasional Contributor

Hi,

Thank you so much for the information.  I hadn't found that reference to the size limit (1GB) yet.  I'm getting a 500 error when accessing the sharing/rest point so I need to track that down. As the faq indicated, we should at least see references and I want to resolve that issue.

However, we don't want the data synced as references.  The 10.7 (we're using) answer to the question seems to indicate that the limit is a portal configuration setting.  Do you know where that is?  We should confirm that setting.

Thanks again.  I appreciate the help.

Mary Ellen

Reply
0 Kudos