Add AGOL Service to Portal for AcrGIS - Store the credentials

1055
16
04-05-2017 06:34 AM
New Contributor III

Hi all

I would like to add a 3D-Service which i published to ArcGIS Online in Portal for ArcGIS. Because it is not a public service i need to input the credentials.

If I insert it to a webmap I need to input the credentials every time? Is there a way to store them in Portal for ArcGIS?

Cheers

Reply
0 Kudos
16 Replies
Esri Contributor

I do receive the same error message as Jake in my environment.

It seems to be a problem with the proxy, which is a proxy with authentication.

Even if the service account user of portal is allowed to access the internet via proxy, it does not work correctly. 

New Contributor II

Hi Stefan

Did you ever find a solution for this? I am trying to view some AGOL layers in Portal and do not want to share them publicly.

Reply
0 Kudos
Occasional Contributor

Hi Chris

I am facing same issue, do you have a clue?

Lakshmanan

Reply
0 Kudos
New Contributor II

Unfortunately I do not.

Reply
0 Kudos
New Contributor II

I'm also looking for a fix for this exact issue. Any updates from Esri?

Reply
0 Kudos
New Contributor II

Did anyone solve this problem. I'm having the same issue ....

Reply
0 Kudos
New Contributor II

The error message is extremely confusing and does not provide any guidance as to what the underlying issue is.

To troubleshoot this I had to reproduce this issue with the browser dev tools open and inspect each response of the network calls manually. There I was able to see some errors around proxy authentication issues.

From there we configured our Portal server to go through our proxy server for server side calls, see - Configure your portal to use a forward proxy server—Portal for ArcGIS | Documentation for ArcGIS Ent...  

I also had to work closely with our network infrastructure team to to make sure that the domains of the AGS services we were trying to use were whitelisted on the proxy server too. Hope this helps.

Reply
0 Kudos