Unable to import this shapefile. (Generate Features error: Exception hostname in certificate didn't match: != OR )

417
11
05-11-2018 09:00 AM
LR
by
Regular Contributor

I've set up an AGE Server (Server, Webadaptor x2, Portal, Data Store) on a single self-certified VM and can't add Shapefiles to a map in Portal - it just throws above error. I GUESS this is because in Portal under Servers I added https://localhost:2443/arcgis/datastore and https://localhost:6443/arcgis instead of MACHINENAME.local/yaddayadda and now the SSL certificate does not match.

However, there is no way to remove that entry. Furthermore, when I try to add the Data Store server with the machine name address, portal tells me "ArcGIS Server is already a federated server". How do I fix this, or isn't this the proper way anyway?

Tags (1)
0 Kudos
11 Replies
JonathanQuinn
Esri Frequent Contributor

You can update the services and admin URL for the federated Server through:

https://<portal>.<domain>.com/portal/sharing/rest/portals/0123456789ABCDEF/servers/<serverID>/update

Set the services URL to https://MACHINENAME.local/yaddayadda and the admin URL to https://MACHINENAME.local:6443/arcgis.

0 Kudos
LR
by
Regular Contributor

I can't go anywhere with portal before my url.

I can go as far as https://MACHINENAME.local/portal/sharing/rest/portals/0123456789ABCDEF/ 

On the 403 pages I can click Log in, which then tells me there's no portal configured. Couldn't this stuff be a bit more user-friendly?

0 Kudos
JonathanQuinn
Esri Frequent Contributor

The portal/sharing/rest endpoint is for the home app and for developers who want to extend, automate, or interact with the Portal outside of the home app. It's available for administrators to use, but it does take some getting used to. Everything would ideally be done in the home app.

The issue in your first bullet is that you're likely not signed in. The issue in the second two bullets are that they aren't valid URLs, (there's no datastore resource).

Navigate to https://MACHINENAME.local/portal/sharing/rest and then sign in at the top right. You should be in as an administrator. Then, navigate to https://MACHINENAME.local/portal/sharing/rest/portals/0123456789ABCDEF/servers/. From there, click on the Server ID and update the server URLs.

You'll then need to update the individual items that were brought over automatically during the federation. This requires you to be signed in as well:

https://MACHINENAME.local/portal/sharing/rest/content/users/<admin> brings you to the administrators content page. Click on the links for the content you have and then at the bottom, go to Update Item. Update the URL of the item, (likely starting with localhost), with the correct URL.

Another option, instead of all of that, is unfederating your Server and re-federating it, using the correct URLs during federation.

Lastly, I suggest you look into the ArcGIS Enterprise Builder, which simplifies the setup of ArcGIS Enterprise on a single machine.

LR
by
Regular Contributor

I unregistered the datastore, but when I try to add it with the correct URL I still get  "ArcGIS Server is already a federated server". So now I don't have anything in the servers list. Trying to add the shape now throws "Generate Features error: Unexpected: no hosting server available".

This test setup is on a single machine but afterwards I'll have to install the stuff across a bunch, so I didn't bother with the builder.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

I think you're mixing up terminologies. There are 4 components to ArcGIS Enterprise:

Web Adaptor

Portal for ArcGIS

ArcGIS Server

ArcGIS Data Store

When you federate Portal and Server, the Server becomes a federated Server. To set it as the Hosting Server, it needs to have a registered ArcGIS Data Store.

I assume you unregistered the machine from the Sharing API. While this removes it from the Portal, it doesn't reset the Server. To have reset the Server as well, you'd unfederate through Portaladmin:

https://<portal>.<domain>.com/portal/portaladmin/federation/servers/<serverID>/unfederate 

To reset Server, go to https://<server>.<domain>.com/server/admin/security/config/update and set the Authentication tier to GIS_SERVER.

Once you've done that, you can re-federate Portal and Server using the right URLs through the home app, (My Organization). ArcGIS Data Store should still be registered to the Server, so you can then set the federated Server as the hosting server.

LR
by
Regular Contributor

I reset Server and entered the correct urls - the shapefile upload now works. Hooray!

I tried the un-federation first but there was nothing listed under /federation/servers/ and I couldn't find the ID either. I only saw it on the registration page before removal..

0 Kudos
JohnBrockwell
Occasional Contributor III

I’m having same issue “Exception: hostname in certificate didn't match”. I have my ArcGIS Server federated.  The server name is https://ArcGISServerMachineName.domain.com:6443 . The Server URL is the web adaptor https://webadaptorname.domain.com/arcgis . The Admin URL is https://ArcGISServerMachineName.domain.com:6443 . Do I remove the web adaptor name or do I give the server the web adaptor name? Not sure which way to go.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Can you take a look at the certificate used for https://ArcGISServerMachineName.domain.com:6443 and make sure that the CN matches ArcGISServerMachineName.domain.com? You can do this directly in the browser.

0 Kudos
JohnBrockwell
Occasional Contributor III

both certificates have the web adaptor machine name. I need a matching certificate for the ArcGIS Server machine with the ArcGIS Server machine name. I guess. My organization is creating there own root and intermediate certificates and the certs were only created for the web tier and not the server and portal machines.

0 Kudos