Unable to Delete Hosted Layers Created by Analysis Widget

653
3
Jump to solution
08-13-2021 09:16 AM
ZachBodenner
Occasional Contributor

Hello,

I've been experimenting with the Analysis widget in the Web App Builder to assist some users with creating hot spot layers. However, I'm having trouble deleting the layers once I've created them. They arrive as Hosted Feature Layers in my org.'s Enterprise Portal, in the folder I directed them to when creating them. I am the current and original owner. When I try to delete them, I either get the error Error:Unable to delete item (if selecting one at a time) or Error:Some items were not deleted because they are delete protected or have dependent items. 

None of them are delete protected according to their item settings, and as far as I can tell there is no reason they would have dependent layers. I created them off a Feature Service published to the federated portal server. No dependent layers have showed up in the publish-to folder. I can't delete them from catalog or my server manager. Any ideas?

0 Kudos
1 Solution

Accepted Solutions
ZachBodenner
Occasional Contributor

Update: I turned the server off and turned it back on again. Everything is behaving normally.

View solution in original post

0 Kudos
3 Replies
JayantaPoddar
MVP Esteemed Contributor

Assuming the items are not delete protected, did you try deleting them from Content page of ArcGIS Enterprise (Portal for ArcGIS) or its item details page?

JayantaPoddar_0-1628872892259.png

 



Think Location
0 Kudos
ZachBodenner
Occasional Contributor

Most certainly, no luck unfortunately.

0 Kudos
ZachBodenner
Occasional Contributor

Update: I turned the server off and turned it back on again. Everything is behaving normally.

0 Kudos