Portal Backup with webgisdr: Server is not started

3561
13
Jump to solution
08-21-2017 07:59 AM
MarkusSchenardi
Occasional Contributor

I'm not able to backup my Portal with the webgisdr tool

Errormessage: The Server https://<domain>/arcgis is not started. The startup timed out.

The referenced URL works fine when calling it manually with the same portal account used in the webgisdr tool.

No special entries in the AGS Log nor in the Portal Log. 

See attached webgisdr.log.

Questions:

  • How can I get more information about errors in webgisdr?
  • Any ideas how to fix the problem?

Additional Information: After removing the federation between ArcGIS Server and Portal, the backup was working. Federated again => not working anymore.

Markus Schenardi
Laixo AG - Zürich - Switzerland
Member of the Esri Partner Network
Tags (3)
1 Solution

Accepted Solutions
jasonwatt
New Contributor II

I had to reconfigure the Web Adaptor for the ArcGIS Server to "Enable administrative access to your site through the Web Adaptor" in order to get the webgisdr backup to run.  However, this opens up publisher and administrator access via the web adaptor. 

View solution in original post

13 Replies
Thor_MortenKopaas
New Contributor

We are seeing the same issue as you are at 10.5.1.

We did have problems with webgisdr at 10.5 as well, but the the error message was a little different. 

For version 10.5 it was:

Failed to generate the ArcGIS Server token from the portal https://myhost.example.com/portal/sharing.
Failed to get the configuration of the web GIS.

Stopping the webgisdr utility.

One difference between your log and ours is that in our the “tokenServicesURL” is empty (“”).

I am in working with Esri support trying to solve this.

0 Kudos
jasonwatt
New Contributor II

I have the same problem with a 10.5.1 deployment where the server is federated.  Have either of you found a solution?  Tail of log file here:

FINER: Deleting the temp directory \\server\share\WebGISSite1234567890.
Aug 28, 2017 9:49:49 AM com.esri.arcgis.webgis.client.WebGISDR main
SEVERE: The server https://example.server.org/path is not started. The startup timed out.
Aug 28, 2017 9:49:49 AM com.esri.arcgis.webgis.client.WebGISDR main
SEVERE: Exiting the webgisdr utility.

0 Kudos
MarkusSchenardi
Occasional Contributor

I was finally ablet to backup my portal but I'm definitely not sure which configuration was the key to success!.

What I changed in my configuration:

Markus Schenardi
Laixo AG - Zürich - Switzerland
Member of the Esri Partner Network
jasonwatt
New Contributor II

I had to reconfigure the Web Adaptor for the ArcGIS Server to "Enable administrative access to your site through the Web Adaptor" in order to get the webgisdr backup to run.  However, this opens up publisher and administrator access via the web adaptor. 

MarkusSchenardi
Occasional Contributor

 I could reproduce it as well: as soon as the administrative access is disabled, the webgisdr tool is not working anymore.

Markus Schenardi
Laixo AG - Zürich - Switzerland
Member of the Esri Partner Network
0 Kudos
Thor_MortenKopaas
New Contributor

Reconfiguring the Web Adaptor for the ArcGIS Server to "Enable administrative access" worked for me as well.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

FYI this will be fixed at 10.6.

ArshaYuditha_Amiranti
Occasional Contributor

My portal and server are configured with IWA and I also face the same issue. Here are the solutions:

1. Make sure the file directory is have enough space.

2. Give your portal and server account a permission to the backup folder.

3. Allow HTTPS Only in ArcGIS Server.

4. I think this is that really makes significant change: Configure the Web Adaptor for the ArcGIS Server to "Enable administrative access".

 

MarkusSchenardi
Occasional Contributor

These ist by the way a confirmed bug:

BUG-000106338 : When admininstrator access is not enabled on a ArcGIS Server's web adaptor, the webgisdr tool for creating an ArcGIS Enterprise backup fails with the error: "The server https://arcgisserver.domain.com/webadaptorname is not started."

Markus Schenardi
Laixo AG - Zürich - Switzerland
Member of the Esri Partner Network
0 Kudos