My services are not updated in Portal when I publish new data to that service?

312
3
12-18-2017 07:05 AM
MichelleRoche1
New Contributor

Hi, I have added a service to a WebMap on Portal and when I add new data to my mxd and then republish the service, the new data is not added to portal? I have to add the layer into my WebMap again.

Can anyone advise me please?

Thanks in advance,

Michelle

0 Kudos
3 Replies
CarmelConnolly
Regular Contributor

Hi Michelle, 

Can you provide some more information please?

What versions of ArcMap and Portal for ArcGIS are you using?

Is your Portal federated with Server?

Where is the data sitting? In a local file geodatabase or in an Enterprise Geodatabase like Oracle?

When you republish, are you using the Overwrite option?

Carmel

0 Kudos
MichelleRoche1
New Contributor

Hi Carmel,

Thanks for replying to my query?

I am using ArcMap and portal10.5 and yes it is federated with server, Data is sitting in an enterprise Geodatabase

And Yes I am using overwrite when I republish?

Thanks,

Michelle

0 Kudos
CarmelConnolly
Regular Contributor

Hi Michelle, 

If everything is set up right, I'd expect edits made to the data in ArcMap would be reflected in the Portal webmap.

Is the enterprise gdb registed with the Server?

When you published, did you enable Feature Access?

Did the process say something like this: ?

If you browse to the item in My Content in Portal, what type is the data? (Feature Layer or Feature Layer (Hosted))

Carmel

0 Kudos