Making NoData pixels transparent on Image Service / Image Layer

243
4
Jump to solution
09-27-2022 03:20 AM
JustinOdell
Occasional Contributor III

Hi all,

I have published an orthomosaic as an Imagery Layer / Image Service. The NoData pixels (R 255, G 255, B 255) are displaying as white and surround the image in a rectangular fashion.

Is it possible to make the NoData pixels transparent once the service has been published? Or can this configuration only be done inside of ArcGIS Pro prior to publishing? If it can only be done prior to publishing, what is the recommended workflow? Ideally, I do not wish to export a new raster if it can be helped.

0 Kudos
1 Solution

Accepted Solutions
JustinOdell
Occasional Contributor III

I ended up right clicking on the raster in Catalog and going in to the properties to change the NoData values. Then republished and voila!

View solution in original post

0 Kudos
4 Replies
TonyContreras_Frisco_TX
Occasional Contributor II

You should set up the mosaic dataset properties to specify NoData values before building your overview images, then publish the service. If the service exists already, I would delete it, update the mosaic dataset according to the help page, then rebuild the overviews and republish the service.

JustinOdell
Occasional Contributor III

I ended up right clicking on the raster in Catalog and going in to the properties to change the NoData values. Then republished and voila!

0 Kudos
CollinJohnston
Occasional Contributor III

@JustinOdell  Same issue here once I publish to a tiled image service on our Portal. Can you clarify what you changed in the No Data option within the raster referenced in your mosaic dataset? 

Did you enter 255,255,255 and then click compute or just select OK? 

0 Kudos
JustinOdell
Occasional Contributor III

Hi @CollinJohnston I believe I queried the NoData pixels in ArcGIS Pro to identify what values they were. In my case they were 255 for all bands. Then in ArcCatalog I went to the properties of the image and edited the NoData pixels such that 255 was the value for all bands. I was then able to publish as an Image Service without issue. I did not click the compute button, but I have noticed when I do this I curiously receive 256 for all 4 bands.