how to configure web adaptor for Portal without fully qualified domain name?

8272
6
07-11-2016 08:36 PM
Amir_FaisalDaud_Ahmad
New Contributor


Hi,

Im currently using version 10.4 for Portal and Web Adaptor.

I have a scenario where i need to implement Portal for intranet. kinda like for internal only using a portable server. Portal was successfully installed and i need to move on to the web adaptor. Configuring the web adaptor for portal requires a FQDN to be used for the portal address.

My current problem is that this scenario does not have any domain. Only a machine name. Can i proceed without the need of FQDN? i tried to input machine name only but i got the error stating that i need FQDN.

i tried to add a dns suffix to the computer name, and i can configure the web adaptor but client computers wont be able to access it since it is not a real domain.

i'm trying to avoid the method to use windows hosts file as it is inconvenient to set in each client machines.

What's the best approach for this situation? Appreciate any ideas..

Thanks.

AF

6 Replies
JayantaPoddar
MVP Esteemed Contributor

In this case, apart from adding a suffix to the machine name, you will need to add the IP Address/HostName of the Serer machine in the HOSTS file (Windows\System32\drivers\etc\hosts)of the client machines. And of course the client machines should be able to communicate with the Serer macine.



Think Location
Amir_FaisalDaud_Ahmad
New Contributor

Hi Jayanta Poddar,

Thanks for the suggestion, i forgot to put that in my question details. I've thought of that but i would like to avoid it as it is a bit inconvenient. Furthermore, will need to modify each client machines.

0 Kudos
SimonJackson
Occasional Contributor III

Can you provide an example of the hosts file for this?  My IP address is not static, so hoping I can achieve a resolution with using the hostname or even localhost?

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

HOSTS file is not designed to be configured for dynamic IPs.

If you are working on a single machine (localhost), you don't need to configure HOSTS. You just need to fool the Portal to think that the HostName is a FQDN (unless the machine has a Domain Name). This can be accomplished by adding a Primary DNS Suffix to the computer Name. Configure the Primary DNS Suffix for a Client Computer 



Think Location
SimonJackson
Occasional Contributor III

Hi Jayanta - saw some of your other similar posts on this topic.

Before reading your above answer, I allocated a static IP to my Win10 Pro machine, and used the hosts file to mimic a FQDN:    192.168.1.18 simon-pc.fakedom

I then installed web adaptor, and registered both server and portal using the fakedom URL.

Right now, I can hit the following endpoints ok:

Have also registered the ArcGIS Data Store (relational, spatiotemporal and tile enabled) with the GIS Server.

Federated the Server with Portal.

I have certificate errors everywhere.  Would like to resolve these.  Was hoping that as everything is on same machine, I could just make use of the existing Self-Signed certificates and install them into the Trusted certificate store.  I don't have a domain controller so cannot generate a domain certificate.

Just reading up on the DNS suffix approach and trying to understand if it would be better for me to backtrack and try that over my current hosts file approach.  What are your thoughts?

DeorajRamsaran4
New Contributor III

Did this work to set up the test env at least? I am looking at this as just a temp option until I can get the domain and SSL certs

Deoraj Ramsaran
0 Kudos