Greetings All, Feature service issue within Portal for ArcGIS

1643
6
07-19-2016 12:57 AM
MostafaMohamed
New Contributor II

Recently I installed Portal for ArcGIS 10.2.1 with web adapter. And after publishing a map service to my ArcGIS server and then adding it as a layer in my Portal's content, I cannot edit this layer even if I checked "feature access" before publishing within ArcMap.

Also I'm using a SDE database.

The layer type in Portal's content is "feature". And I'm only allowed to see it's attributes , symbolize, etc. However I cannot edit it and also when editing the layer settings I cannot see any configuration for editing and routing.

Thanks in advance.

Tags (1)
0 Kudos
6 Replies
JayantaPoddar
MVP Esteemed Contributor

You might need to federate your Portal for ArcGIS with ArcGIS Server site and define the GIS Server as your hosting server.

http://server.arcgis.com/en/portal/10.3/administer/windows/about-using-your-server-with-portal-for-a...



Think Location
MostafaMohamed
New Contributor II

Thanks Jayanat for your respond. I will try to federate my Portal with ArcGIS Server.

0 Kudos
MostafaMohamed
New Contributor II

Sorry, Jayanta*

0 Kudos
MostafaMohamed
New Contributor II

Hi Jayanta,

It works now. the issue is tat I took the wrong service URL from ArcGIS server. I took the map URL instead of Feature access URL.

Appreciate your help.

DerekLaw
Esri Community Moderator

Hi Mostafa,

You did not need to federate your Server site with Portal for ArcGIS (nor set-up a hosting server) to enable feature services from a Server site to be accessible in Portal and editable.

Please check that before you published your map service (with the "feature access" enabled) in ArcMap, that you've met all the requirements to author feature services correctly,

Author feature services—Documentation | ArcGIS for Server

Hope this helps,

MostafaMohamed
New Contributor II

Hi Derek,

Thank you very much. I can edit layers within Portal now. Now I will try to use collector for ArcGIS.

Thanks again.

0 Kudos