ArcGIS enterprise portal is too slow when using cloudflare proxy

1408
6
03-01-2022 06:13 AM
gsiarc
by
New Contributor II

hey there we have installed arcgis enterprise portal 10.9.1 the portal is extremly slow and it's get more slower after using a cloudflare proxy on the domain name any idiea ?

Tags (3)
0 Kudos
6 Replies
Brian_Wilson
Occasional Contributor III

Do you mean it's slow from outside on the Internet when going through the proxy? If that's the case, it's really easy to turn off proxying for that entry in Cloudflare and see if the problem goes away. That would be the first thing I would do. 

If you mean it's slow on your internal network when Cloudflare is running then you should be setting up an internal DNS to resolve the name locally. That is, when you hit the URL it should not be giving you the outside IP address because there is no reason to do that.

When I am outside, my host name resolves like this, a non-routable internal address

bwilson@cc-TestMaps:~$ dig geoserver.wildsong.biz
...
geoserver.wildsong.biz. 300     IN      A       104.21.42.186
geoserver.wildsong.biz. 300     IN      A       172.67.208.22

Local:

(base) bwilson@bellman:~/.ssh$ dig geoserver.wildsong.biz
...
geoserver.wildsong.biz. 0       IN      A       192.168.123.2

 

If you are getting a Cloudflare proxy address on your internal network then the packets for a request to your own server go out, through a Cloudflare proxy cache server, then back into your network, then back to Cloudflare then back to your client. 

0 Kudos
gsiarc
by
New Contributor II

Yes, when i turn off the proxy it’s back to normal but i use it for security because it’s hide my real ip i dont have a proplem with my internal network when access from inside the network I’m talking about the out side users 

0 Kudos
Brian_Wilson
Occasional Contributor III

Interesting so maybe you want to try this... I wonder how long "Temporarily" is -- maybe until you turn it back on? This affects the entire domain, which might or might not be bad for you. The popup when you turn it on says (in part) "Cloudflare will continue proxying traffic to your origin server without caching any content."

BrianWilson7_0-1646172929372.png

 

0 Kudos
Brian_Wilson
Occasional Contributor III

If "Development Mode" fixes it then you can put in up to 3 Page Rules per domain in the free level of Cloudflare service. (Assuming you like me use the free level!)  Then you can set "Cache Level" to "Bypass Cache". I look forward to hearing if this works. 

gsiarc
by
New Contributor II

i already tried that but i noticed the latency is very high when requesting web page files and scripts

Screen Shot 2022-03-02 at 1.43.52 AM.png

0 Kudos
Brian_Wilson
Occasional Contributor III

Yes WHOA that's bad. Now I have to test this to see what it does to me! Looks like you are hitting a WAB app.

 

0 Kudos