ArcGIS Dashboard does not display properly on the second monitor

246
4
05-07-2021 01:33 PM
NABAZGHARIBMOHAMMED
New Contributor III

Hi all,

I created a dashboards and embedded an application in the dashboards. It works fine, but I am facing a strange issue, I have two screens, when I open the dashboard in the second monitor, the map in the app, which embedded in the dashboards, dose not  render  and it stuck, no move , no zoom in or out.

However in the main screen, the laptop screen, it works fine.

I checked the DevTool of the browser, It displays these error messages:

init.js:596 TypeError: Cannot read property 'getValue' of undefined
at d.Animation._play (init.js:249)
at init.js:63
at d.Animation.play (init.js:248)
at Object.__setExtent (init.js:593)
at Object._extentUtil (init.js:591)
at Object._wheelZoom (init.js:1314)
at Object.<anonymous> (init.js:63)
at Object.c [as onMouseWheel] (init.js:119)
at Object._fire (init.js:1339)
at Object._onMouseWheelHandler (init.js:1347)

NABAZGHARIBMOHAMMED_0-1620419766677.png

 

I am  using ArcgGIS Enterprise version 10.6.1 on window server.

 

Tags (1)
0 Kudos
4 Replies
JonEmch
Esri Regular Contributor

When you run into this error, do you see any logs being generated at the ArcGIS Server level?

Keep on keeping on!
0 Kudos
NABAZGHARIBMOHAMMED
New Contributor III

No severe messages, except some warning or info.

0 Kudos
JonEmch
Esri Regular Contributor

I would set the logs to debug and try again (remember to do this is settings, not at the filter, then turn them off after investigating). Could you give me any more info about the application you are using?

Keep on keeping on!
0 Kudos
NABAZGHARIBMOHAMMED
New Contributor III

But there is something I noticed, if I run the application alone without embedding it in the dashboards, it works without any problem,
however that issue happens when I open the dashboard that has the application embeded in.

0 Kudos