Adding Built-in Portal Members from a CSV file not working.

379
1
08-05-2019 07:51 AM
AbiDhakal
Occasional Contributor

Hello GIS friends,

It is Monday and we are all hard at it and I am no exception!  

I am trying to batch load built-in Portal members/users from a CSV file but it is not working for me. It says I need to have a CSV file that must contain a header (first line) with these field names: Email, First Name, Last Name, Username, Password, Role and Level. I have what it says I must have. It even lets me upload the file and review, but when I go to add members it says unable to add the following members and lists the entire member list. What am I doing wrong folks? Please send suggestions.

Thank you much and have a great day!

Abi

1 Reply
DirtDogRoj
New Contributor III

I had this same issue but I figured it out.  It had to do with the strength of the passwords.  Initially, I got a green check mark showing that the password was fine, in the same screen that shows that the names and email addresses were fine.  But then when I got to the list of users in the wizard, I clicked one of them to see their properties, and that's where I saw the red bar that indicated the password wasn't strong enough.  After changing the password to a stronger one in the CSV and resubmitting it, the wizard added them successfully.  I want to add that, I, too, was getting a list of all the users not being added, because I had set the same password for all them.  If the list had contained a combination of weak and strong passwords for different users, I imagine that only the strong would have survived. 🙂

0 Kudos