ArcGIS Pro Cityworks SOE

1503
12
12-28-2017 11:29 AM
Highlighted
New Contributor III

When I publish a service to our Server through ArcMap, the ability to turn on the Cityworks SOE is available as are many other options.  Those options are also available within ArcGIS Server Manager.  If I publish a Service through ArcGIS Pro, I have no option to turn on the Cityworks SOE.  I also do not have the option to turn on the Cityworks SOE Capability after it has been loaded to server.  Am I missing something, or can we not turn on SOE capabilities from layers served up from Pro?

Options from ArcMap Service

Options from ArcMap

Options from ArcPro Service

Options from ArcPro

Tags (3)
12 Replies
Highlighted
Occasional Contributor

Same for SOIs

Highlighted
New Contributor

There is an open bug w/ Esri for this issue...#BUG-000110249 The option to enable SOEs and SOIs on services published from ArcGIS Pro to ArcGIS Server does not exist in ArcGIS Server Manager or ArcGIS Pro. This applies to all SOEs/SOIs, not just Cityworks...any SOEs/SOIs constructed. The workaround they have is also not sufficient...which is to simply modify the resulting GIS Service via ArcCatalog. This has been shared w/ Esri...the workaround does not work if the GIS service was published as a web layer from Pro originally…at least, not in the current production version of 2.0.1...so basically if you want to be able to utilize any SOE, publish from ArcMap/ArcCatalog to begin w/…then you can enable the SOE capability in the dialogue while publishing from ArcMap or afterwards thru the Capabilities form for the service just published from ArcMap. This bug was discovered in both the current version of Pro, 2.0.1 (w/ ArcGIS Server Enterprise 10.5.1) & Pro 2.1 (w/ ArcGIS Server Enterprise 10.6 PreRelease).This appears to have to do w/ some config setting in a file read by ArcGIS server...something Pro just doesn't set, so ArcGIS Server can't do anything about it.

Highlighted
New Contributor II

Well, it's 14 months later and apparently this still hasn't been fixed.  I'm standing up new ArcGIS Enterprise 10.6.1 infrastructure, and can't get map services published from Pro 2.3.1 configured to use the Cityworks SOE.

Reply
0 Kudos
Highlighted
New Contributor III

When I publish a layer through Pro, I notice the Cityworks SOE is now an option in my server environment.  I have yet to test it though, but it does show up for me.  You'll have to turn it on in Server, as it isn't an option to turn on in Pro when publishing.

Reply
0 Kudos
Highlighted
Occasional Contributor

Darren, what version of ArcPro and Python are you using? I'm on ArcPro 2.3.2 and Python arcgis 1.5.3 and still hitting this problem.

Reply
0 Kudos
Highlighted
New Contributor III

Don,

You are correct.  I know several months ago when I published a service from Pro, the Cityworks SOE was showing up for me when I checked the service in server.  Now when I look at a recently published service from Pro, I do not see the option any more.  We are running server 10.6.1 and Pro 2.3.2

Highlighted
Honored Contributor

I have the same issue!

 

The “Cityworks.GIS.SOE.soe” file is not recognized by map services published by ArcGIS Pro

Highlighted
New Contributor III

You have to contact Cityworks to request the SOE that supports services published from Pro. The SOE with ArcMap provider can only work with services published from ArcMap. Once you receive the SOE that supports services published from Pro, you can deploy the SOE to ArcGIS Server (10.6.1 or later version is required).

Highlighted
Occasional Contributor

Thanks Hanhan - this seems to explain our problem. I found an example that illustrates selecting the proper platform. I'll give it a try in the next couple of days.