License Manager in 10.5.1 - Having trouble connecting

1425
4
11-03-2017 11:29 AM
JenniferHigbie
New Contributor

I upgraded our system to 10.5.1, including desktops and enterprise.  In the process, the license manager was moved to a new server.  It was deauthorized, moved, and reinstalled.  The license manager appears to be working properly and reading the correct number of licenses.  When in ArcGIS administrator, I'm trying to point the desktop software to the new license manager and I'm getting an error that there is no license manager on that machine.  I've checked the ports and they are open.  I assigned a specific port (27001) and have had no luck.  Any suggestions?

0 Kudos
4 Replies
JayantaPoddar
MVP Esteemed Contributor

Is the ArcMap (ArcGIS Administrator) also of version 10.5.x?

Check the running status of the License Manager? Is it running?

Else try changing to a different port (say 27004).

0 Kudos
JenniferHigbie
New Contributor

Administrator is same version.  It's all been upgraded to 10.5.1.  The license manager is running, reading the correct number of licenses, and the diagnostic on it says everything is fine.  We've tried multiple ports and none appear to be working.

0 Kudos
V_StuartFoote
MVP Frequent Contributor

Is your networking IPv6?

Check what your DNS resolves the address to, i.e. what you get with a ping.  You may need to enter the license service at its IPv4 address, or even its IPv6 address.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Try setting up the FLEXLM_TIMEOUT environmental variable.  This helps many of our users that have issues connecting.  (copied from our internal troubleshooting page)

To help speed up connections to the license manage, especially in offices with slower connections, the response to the new license manger setup may timeout with the error “The server entered is not a valid ArcGIS License Manager” (or maybe a -15 error)
First see instructions for setting your machine to the new license manager server.
If still having issues (especially in offices with slow network connections), go to the Environment settings…and “add the System Environment Variable “FLEXLM_TIMEOUT” with value 1000000”
• Right click on My ComputerPropertiesAdvanced System Settings->Advanced
• click on Environment Variables button, click NEW to add a new variable.
New Picture (22).bmp
• then, under System variable, select “New”, for name enter FLEXLM_TIMEOUT and for value enter 1000000
New Picture (23).bmp
Once ArcGIS is installed, verify the variable was configured properly by opening StartAll ProgramsArcGISDesktop Administrator. On the main page at the bottom, the screen should have the following: Variable Name: ARCGIS_LICENSE_FILE and Variable Value as shown above.
0 Kudos