Beware when upgrading to Windows 10, ArcMap consistently crashes when an MXD contains a Raster and is left open more than an hour.

2153
6
01-11-2017 09:09 AM
DanielWilson
New Contributor III

Various Raster types  have been tested and  7 out of 12 have consistently crashed in 10.3.1. and 10.4.1 on Windows 10.  This issue was not reproducible in Windows 7.  The BUG has been reproduced by ESRI, please reference BUG-000101623.

6 Replies
MichaelVolz
Esteemed Contributor

Do these crashes occur if you are actively working in the mxd for over 1 hour or only if you leave the mxd idle for an hour?

0 Kudos
DanielWilson
New Contributor III

The crashes occur in both scenarios.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

That is strange, I have run windows 10 and with arcmap 10.4 or10.41 for a couple of years.  

I have a raster in my project all the time and I have never had a crash... going on 2 years now ... and my machine is on about 14 hours a day.... sometimes working constantly, sometimes with 2-6 hours of inactivity

In my situation I always work with:

  • locally stored data (no network, no cloud, no usb)
  • my rasters are generally esri grids (the occasional tiff for background imagery)
  • with a standalone advanced licence
  • the only other software I run at the same time is Edge (browser), File Explorer and python (usually Pythonwin, pycharm and spyder at the same time)

Is there any difference in my setup than yours?

0 Kudos
mpboyle
Regular Contributor

Is there any documentation on Esri's Support site specific to this bug?  I'm unable to find anything.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

here is the link

Fixed in 10.5.1 (????) the comments say 'certain layer configurations' and no workaround.

As I noted, I have never seen this, so replicating might be tricky.

But it is a duplicate of this bug if you have a single band raster with a stretch applied.

NathanBruce1
New Contributor III

Currently seeing this now with fresh installs of 10.5 and 10.6 on a brand new WIN 10 PC's.  MXD's that worked fine on older PC and 10.5 now crash after idle and also have issues with services consumed from our AGOL Org.  No solution from Esri after trying many things, this might be a new lead.  Thanks

0 Kudos