Another 10.3.1 License Server Problem

3531
10
03-18-2016 04:46 PM
PaulHuffman
Occasional Contributor III

I want to replace my old 10.2.2 license server running on a old XP with 10.3.1 License Server running on a new server running Windows Server 2012R2.  On the Server 2012,  the License Server Administer shows that the provision file was authorized and my license are available,  service is started.  Desktop 10.3.1 locally on the Server machine gets served a license successfully.  But on my network, client PCs running 10.3.1 and 10.2 can't get a license but they can find the license server host on a network browse.  I used Windows Firewall with Advanced Security on the LM host to open 27000-27009 inbound and outbound, my Service.txt file for  License 10.3 looks like it is using 27000:

SERVER this_host ANY 27000

VENDOR ARCGIS

USE_SERVER

FEATURE ACT ARCGIS 1 permanent 1 vendor_info=7KNJDRHFHBK4CFDMJ214 SIGN="052E ABFC 32DD \

    2473 DEFD E276 4BF3 E0DB 87EB 2203 5A30 C014 19A1 C35E 2154 \

    08B1 9460 A2B9 6701 DC4D CAF2 E2FE 1347 0E36 90FA 4F3B E864 \

    BEC8 D3A2 A615"

Client PCs just get the old "'YourCrappyHost' does not have a valid License Manager." message,  but somewhat slower after I messed with the firewall.

I'm out of tricks.  How do I fix this?

0 Kudos
10 Replies
V_StuartFoote
MVP Frequent Contributor

Paul, *

From one of your clients, do a nslookup for the 'YourCrappyHost'  name.

Is DNS responding with IPv4 or IPv6?

0 Kudos
PaulHuffman
Occasional Contributor III

This virtual server was set up two weeks ago by my co admin. and this week he's off floating the Owyhee. There's some network topology here I don't get. His docs say server NSMAP is at 192.168.3.223.  I can remote desktop log on to NSMAP by using the name, not the IP address.  Ipconfig on the server shows an ipv4 of 192.168.3.43.  But on a client Windows 10 PC, I can't ping either IP, and nslookup of 3.43 or 3.233 seems to jump to google:

nslookup 192.168.3.223

Server:  google-public-dns-a.google.com

Address:  8.8.8.8

*** google-public-dns-a.google.com can't find 192.168.3.223:  Non-existent domain

But on the client PC, ArcGIS administer >Desktop>Change>Browse will display NSMAP in computer you want to connect to:  and Remote Desktop works with the host name, but neither IP.

Turning the windows firewall off temporarily on the host did not help with connecting with ArcGIS Administrator.

0 Kudos
V_StuartFoote
MVP Frequent Contributor

The server should have a static IP, if set via DHCP as this seems to have been, you need to reserve its IP by MAC--but you're really hosed if the VM is spinning up virtual MAC.

Then reset your DNS service, and flush the DNS cache.  Should get back to reasonable IP/MAC relationship.  Need to do that so you can deal with FlexNet Publisher Trusted Storage authorizations.

Fun isn't it.

0 Kudos
PaulHuffman
Occasional Contributor III

The other admin surprised me by stopping in on Monday before leaving for his river trip.  He saw his mistake and corrected it. Now the license host has a fixed IP address.  But I still can't get a license delivered to a client PC.  I flushed the DNS cache and tried adding a fixed PORT in service.txt, but now the client Administrator seems to fail quicker. 

I've already tried to open ports 27000 to 27009 inbound and outbound on the host. 

service.txt now looks like

SERVER this_host ANY 27000

VENDOR ARCGIS PORT=27000

USE_SERVER

FEATURE ACT ARCGIS 1 permanent 1 vendor_info=7KNJDRHFHBK4CFDMJ214 SIGN="052E ABFC 32DD \

     2473 DEFD E276 4BF3 E0DB 87EB 2203 5A30 C014 19A1 C35E 2154 \

     08B1 9460 A2B9 6701 DC4D CAF2 E2FE 1347 0E36 90FA 4F3B E864 \

     BEC8 D3A2 A615"

0 Kudos
V_StuartFoote
MVP Frequent Contributor

Paul,

You can not bind both the lmgrd.exe and the arcgis.exe FlexNet executables to the same port.

See this 10.3 Help article:

Configure ArcGIS License Manager to work through a firewall—Help | ArcGIS for Desktop

Stuart

PaulHuffman
Occasional Contributor III

Thanks. I changed the Vendor Port to 1234,  now I have a local license, but not client.  So I guess I need to make an exception in Windows Firewall for 1234.  Is that inbound or outbound?

I just used Action>New Rule>Port>Specified local ports>1234>Allow the Connection>Applied to all,  and it works for a client machine.  Is that too much permission?

0 Kudos
V_StuartFoote
MVP Frequent Contributor

Paul Huffman wrote:

Thanks. I changed the Vendor Port to 1234, now I have a local license, but not client. So I guess I need to make an exception in Windows Firewall for 1234. Is that inbound or outbound?

I just used Action>New Rule>Port>Specified local ports>1234>Allow the Connection>Applied to all, and it works for a client machine. Is that too much permission?

The exception would be on the Server's firewall, incoming either open the port (but set the allowed subnets) or for the arcgis.exe program (again setting the allowed subnets).

Stuart

0 Kudos
PaulHuffman
Occasional Contributor III

All right!  I just tested another client PC running 10.2.2, and it's getting license service, too.

PaulHuffman
Occasional Contributor III

Now licenses aren't available to the host either.  Here's a mystery, License Server Administrator shows on the status line NOT RUNNING, and the Start button doesn't work to get the service started.  Yet, when I look at services, both ArcGIS License Manager and FlexNet Licensing Service are running. 

Did I mess with service.txt too much?

0 Kudos