Unable to display ecw files in Arcatalog

485
3
Jump to solution
07-31-2019 01:38 PM
JimmyMaro
New Contributor

I m unable to display .ecw files in Arcatalog. My Arcatalog version is 10.4. I never had the problem until after re-installing Desktop ArcGIS. Can someone assist?

0 Kudos
1 Solution

Accepted Solutions
NeilFordyce
New Contributor III

I was with Jimmy when we sorted this problem (I hope). Jimmy was connecting to the data by UNC paths and the servers had been changed to dfs servers and the path was too long. 

Connecting to the mapped network drive letter solved viewing the ECW in 10.4

View solution in original post

0 Kudos
3 Replies
LanceCole
MVP Regular Contributor

Jimmy,

ArcCatalog 10.4 should naively support ECW.  You can try and uninstall and reinstall ArcGIS or look in to installing ECW for ArcGIS Desktop plug-in 10.4 available from Hexagon Geospatial.  10.6 had a known issue and required a patch for ECW but you indicated you are running 10.4.

You can also take a look at the following posts:

Arcmap 10.4 won't open ecw 

Resetting your ArcGIS application profile 

Also note Jayanta Poddar‌'s additional recommendation to make the following registry changes after resetting your ArcGIS application profile.  Carefully consider this before attempting, editing a ESRI registry is not recommended.  

Also make following changes to registry

  1. Press the Windows Key in conjuntion with the "R" key on your keyboard and type "regedit" - this will open the Windows registry editor.
  2. Navigate to:  HKEY_LOCAL_MACHINE > Software > ESRI and rename the "ESRI" folder to "ESRI_OLD".
    Note that on a 64-bit machine, the location is HKEY_LOCAL_MACHINE> Software> Wow6432Node> ESRI
  3. Navigate to: HKEY_CURRENT_USER > Software > ESRI and rename the "ESRI" folder to "ESRI_OLD".

*Note: The templates of ArcGIS Desktop (ArcMap/ArcCatalog/ArcScene) will be set to default.

Reboot machine and start ArcMap.

LaureneKoman
Occasional Contributor III

clarification this registry location should not be renamed or altered while Esri products are installed.  If this is renamed while ArcGIS Desktop is installed, the apps won't function. 

  1. Navigate to:  HKEY_LOCAL_MACHINE > Software > ESRI and rename the "ESRI" folder to "ESRI_OLD".
    Note that on a 64-bit machine, the location is HKEY_LOCAL_MACHINE> Software> Wow6432Node> ESRI

The HKCU entries are created by the applications and will regenerate if deleted. 

0 Kudos
NeilFordyce
New Contributor III

I was with Jimmy when we sorted this problem (I hope). Jimmy was connecting to the data by UNC paths and the servers had been changed to dfs servers and the path was too long. 

Connecting to the mapped network drive letter solved viewing the ECW in 10.4

View solution in original post

0 Kudos