Can you run an RBJ in ArcMap 10.7.1 that was created in ArcMap 10.4.1/10.5.1?

39
1
08-12-2020 02:17 PM
Highlighted
New Contributor III

We run the same RBJ in 10.4.1 where it was created and receive little to no errors. Upon running the same RBJ in 10.7.1, there are errors on almost every record in every feature class in the entire geodatabase. Must the RBJ be recreated in 10.7.1? Is there a tool to automatically convert it to a higher version without having to re-do it all manually? This would be a major downfall of ever upgrading to a higher ArcMap/Enterprise version.

Reply
0 Kudos
1 Reply
Highlighted
New Contributor III

Hi Shannon,

You can use the Batch Job created in 10.4.1 in 10.7.1 with no issues. But if you want to upgrade the batch job version, open it in ArcMap 10.7.1 Batch Job Manager and save it. Your batch job will be upgraded to 10.7.1 version.

For the difference in number of errors between two versions, please check some of the new errors you are getting in 10.7.1 and confirm if they are correct. My guess is because of the bugs resolved in between versions(10.5 - 10.7.1), you are now getting more accurate results.

Please let me know if this is the case or you are getting incorrect results. 

Thanks,

Kumar Gaurav

Reply
0 Kudos