How can I unable Advanced formatting when I Enable it in Indicator?

369
4
Jump to solution
09-27-2021 01:12 PM
Labels (1)
ARM
by
New Contributor III

Hello,

When I enable Advanced formatting in Indicator at dashboard I can't go back to default view without losing my setting in data to general and I need to start everything from beginning.

is this a bug or I am missing something?

Best 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
EmilyMcLeanACTGOV
Occasional Contributor

Hi @ARM , 

The video shows what I was seeing, it is just that your advanced formatting that you have applied is pulling in additional information (I can't see the full arcade expression for bottom text, but it starts with $reference...). Because the information being pulled in is being accessed via arcade, it stands to reason that you will not be able to see the additional information (no. of total inspections) once you cancel advanced formatting. You will see that the middle text ($Datapoint["count"]) continues to display even when you cancel advanced formatting (which is why you are still able to see "0"). So this is expected behaviour. 

If you jut want to remove specific formatting options, while still keeping the additional information that you are accessing through arcade, the easiest way is to simply stop referencing hex codes/ icons in the advanced formatting window. 

 

Emily

View solution in original post

0 Kudos
4 Replies
EmilyMcLeanACTGOV
Occasional Contributor

Hi @ARM ,

You are able to disable advanced formatting by selecting the trash-can symbol (next to the expand panel symbol) at the top of the indicator options tab when editing the dashboard element. After selecting the trash-can symbol, you're asked to confirm that you want to remove the advanced functionality. Once confirmed you will be able to see the usual Top Text, Middle Text, Bottom Text set-up. 

Hope this helps. 

 

 

Emily
0 Kudos
ARM
by
New Contributor III

Hello @EmilyMcLeanACTGOV 
you right about this and I am aware of this but the problem is this;
When I click on trashcan and confirm you need to do everything again in data, Indicator and general tabs. I couldn't find a way for this. Lets say you change your mind and don't want to work with Arcade or by mistake you click on Advanced formatting. By confirming you lose your other set up too.
  

0 Kudos
EmilyMcLeanACTGOV
Occasional Contributor

Hi @ARM , 

I have not found this.

When I have confirmed that I am no longer looking to use advanced formatting, everything simply reverts to the standard datapoint value of the layer that I had previously chosen. 

When you have made updates within the advanced formatting space, have you removed the "$datapoint[]" value from the return section? 

Thanks,

Emily
0 Kudos
EmilyMcLeanACTGOV
Occasional Contributor

Hi @ARM , 

The video shows what I was seeing, it is just that your advanced formatting that you have applied is pulling in additional information (I can't see the full arcade expression for bottom text, but it starts with $reference...). Because the information being pulled in is being accessed via arcade, it stands to reason that you will not be able to see the additional information (no. of total inspections) once you cancel advanced formatting. You will see that the middle text ($Datapoint["count"]) continues to display even when you cancel advanced formatting (which is why you are still able to see "0"). So this is expected behaviour. 

If you jut want to remove specific formatting options, while still keeping the additional information that you are accessing through arcade, the easiest way is to simply stop referencing hex codes/ icons in the advanced formatting window. 

 

Emily

View solution in original post

0 Kudos