Sync errors with Collector offline

25915
45
Jump to solution
03-18-2014 04:20 PM
CarmaGerber
New Contributor
Hello fellow Collectors!

I am happy to have downloaded the new version of Collector. I have successfully set up a map for offline editing, downloaded it to my device and collected some features.

Seems to be a bit sticky syncing back though. I have had 2 REST API errors (this is what they appear to be) so far relating to sync'ing the replica.

Both appeared to be a rollbackOnFailure error.

The difference being:

1st error - gave me an 'error synchronizing replica' message that contained the GUID for the feature I was syncing (I only had 1 to sync). Then when I checked the map in browser AGOL, the feature I was syncing was there, so perhaps an error that wasn't actually an error.

2nd error - didn't show me a GUID however I was syncing multiple features. These did not appear in my map in the browser, so a genuine error.


Any ideas here?

Carma Gerber
Esri Australia
Tags (2)
Reply
0 Kudos
45 Replies
FrankPotempa
Occasional Contributor

Just wanted share that there is a similar thread here;

Editable feature service, and query only feature service, in single offline Webmap?

Frank

Reply
0 Kudos
mpboyle
Regular Contributor

Frank,

We have a similar setup (details below) where the web map has an editable layer and read-only layers (query and sync only).  As mentioned above, we only get this error on iOS devices, not Android.

We also have the same behavior, whereas the edits are pushed to the database despite the error.  As you mention Frank, it's a little uncomforting to the user, but it does work.

Thanks for confirming!

Collector 10.3 for iOS

ArcGIS Server 10.3

SDE 10.3

ArcGIS Online as the portal

Reply
0 Kudos
FrankPotempa
Occasional Contributor

If you refer to the thread here, Editable feature service, and query only feature service, in single offline Webmap?

ESRI says to try by adding the Update capability with Query and Sync enabled. I can confirm that this does work but it also lets the user choose to update an existing layer that one may want RO. Again this is more of an inconvenience so far in the workflow and I would guess this is not how ESRI intended it to work. Looking for ESRI to chime in with any qualifications or further suggestions on this issue.

Frank

Reply
0 Kudos
EduardoAbreu-Freire
New Contributor III

Encryption in the .geodatabase (collector local storage DB file)!?

Trying to successfully run tool copy runtime to file gdb or export to XML + import XML into gdb on .geodatabase file, we figured the file which the tool could not open has some kind of encryption. This issue showed up opening the file with BD Browser for SQLite.

How can we open it? Where and why Collector encrypts some and others does not?  

Reply
0 Kudos
OBVYamaska
New Contributor II

Hi Russell Roberts
I'm still facing this issue.

I tried unsynching/resynching/remove editor tracking my layers, have no copied layers.

I downloaded the .geodatabase files from the iPad and tried to use the copy runtime to file gdb tool. This worked for some, but not all (and you'd guess, not the ones I need) of the runtimegeodatabases.

These geodatabases have attachments.

The error I get from the tool: can't copy the file

ERROR 001732: Cannot copy datas from the runtimegeodatabase

I tried shortening the path to it's simplest expression to no avail.

Any leads on how to avoid the issue with the sync in the first place?

And then, how to recover these datas?

Thanks!

Reply
0 Kudos
RussellRoberts1
Esri Frequent Contributor

I no longer work on Collector app but I am looping in Miaogeng Zhang to see if  he can help you out. You might want to see if you can share the zipped gdb with Morgan.