Pop-up Not the Same Between WebMap, Collector, and Collector Classic

240
5
11-19-2019 09:04 AM
AprilChipman
Occasional Contributor III

I've created a webmap and enabled and configured pop-ups on different layers. Collector (version 19.2.0.2714) for iPad is not showing the pop-ups correctly. In fact, it is showing pop-ups for layers that I have *disabled* the pop-up, and not showing pop-ups for the layers that I have *enabled* pop-ups.

To get even more confusing, I can search for a feature in the layer that should have pop-ups (but isn't working) and the search function selects the feature and brings up the pop-up perfectly. I can close the search window, select the same feature, and no pop-up.

I've tried this same webmap in a webapp and Collector Classic. The pop-ups work exactly as configured in the webmap. I've tested the process on another iPad with the same results.

Is anyone else experiencing this? Anyone know what is wrong?

Thanks,

April

Reply
0 Kudos
5 Replies
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Hi April - Are you creating your map in Map Viewer Beta, or the current Map Viewer? Is this a map you'd be able to share with me (by adding it to a group and inviting user Collector4ArcGIS to that group)?

Reply
0 Kudos
AprilChipman
Occasional Contributor III

I created the map in the current Map Viewer. I can try to share it.

Reply
0 Kudos
kmsmikrud
Occasional Contributor III

Hi April,

I'm having the same issue today with my configured pop-ups not showing the same in Collector for ArcGIS. Did you figure out anything?

Thanks,
Kathy

Reply
0 Kudos
AprilChipman
Occasional Contributor III

Unfortunately, no.  This issue has been logged with ESRI as a bug. I am not sure if or when it will be corrected.

#BUG-000127668 An inconsistent behavior for the configured pop-up is returned when the entire service, rather than a particular layer in ArcGIS Online web map, is added.

Reply
0 Kudos
kmsmikrud
Occasional Contributor III

Thanks April for the update and bug number. Have you been able to create a work around in the interim or gotten it work with a new web map? Thank-you!

Reply
0 Kudos