Parcel Fabric Published Feature Service Editing in Collector

138
3
08-23-2020 11:37 PM
Esri Contributor

I have created a Parcel Fabric Model using ArcGIS Pro 2.6 and Publish it on ArcGIS Enterprise 10.8.1; whenever I am trying to test editing Parcel Point Feature Service (such as moving Point location) using Collector (or the new ArcGIS Field Map iOS App), I receive an error message that the Point is missing Z Coordinates;

I tried several scenarios including updating the feature service definition to disable the HasZ parameter with no luck.

Any help either how to disable the HasZ for a publish feature service (I cannot simply copy the feature class to a new one as it will lose its connection with Parcel Fabric model); or to enable Collector to pass a Z value while collecting or updating Point location?

Reply
0 Kudos
3 Replies
by
New Contributor III

Hi, Khaled

What version of Collector are you using? Is it on Android or iOS devices?

When you take your device outside to collector data for the feature layer in Collector, tap on the GPS bar and open the GPS details page, do you see the Altitude data in the GPS details?

Reply
0 Kudos
Esri Contributor

Hello Rui,

I used Collector for ArcGIS on iOS latest release and I tried as well the new Field Map iOS beta; same behavior. Note that I was trying to use the mobile inside my home not outdoor; not sure if this will make a difference or not. I've set the altitude attribute to 1 as a default value.

Reply
0 Kudos
by
New Contributor III

Khaled, 

when you are inside your home and collect data using GPS, if you see the GPS details that has no Altitude (as in the following attached image), that may be the reason the app is giving error message. 

If you are adding or editing point data manually, did you check if the point layer allows null values for the Z field? The Parcel Fabric Model may have special Attribute Rules for point feature layer. Parcel fabric data model—ArcGIS Pro | Documentation 

GPS Details without Altitude

Reply
0 Kudos