I made my layers editable and I still can't see my map on my device in Collector for ArcGIS

2904
11
12-10-2016 07:35 PM
by Anonymous User
Not applicable

I went through the training exercise, well and good, it worked.  I created a second very simple map with two point shapefiles with simple attribute tables.  Saved my map.  Wouldn't open on iOS devices in Collector for ArcGIS (doesn't even appear on the list of available maps).  Web said I needed to make my layers editable.  So I did.  Still not working.  Went back to double check and THE ABILITY TO SET EDITING WAS GONE (See screenshot).  Logged out and in.  Again.  Went back, THE ABILITY TO SET EDITING RETURNED (See second screenshot) and the layers showed as editable, but still, the map doesn't appear in the list of available maps on the iOS devices.  I went back to the map created in the training exercise, added the new shapefiles, double checked that they are set as editable.  The map does appear in the list, and does open, but those to shapefiles do not.

What are I doing wrong?  

Thx

0 Kudos
11 Replies
GISSupport3
Regular Contributor

You also need to share the map to a group.

0 Kudos
AdamZiegler1
Esri Contributor

I've seen this before. When a webmap is created with a feature layer that is uneditable you need to open the map and save it again, after the feature layer is changed to allow editing.

So, you have a webmap not showing up in Collector because the initial feature layer was uneditable. Do the following:

  1. Open feature layer and change settings to allow edit operations
  2. Save the changes
  3. Open web map that consumes recently modified web layer
  4. Save the webmap
  5. Web map should be available in Collector

-Adam Z

by Anonymous User
Not applicable

Thanks, Adam.

Actually, I had already changed the settings to allow edit. Maddeningly,

sometimes that ability was and sometimes was not available. But the first

time it was available, I enabled editing, and the second time, I confirmed

that editing was enabled. As I said in my post, still no cigar. But

oddly, several hours later, after no effort on my part, the data did show

up on the iToys.

I just got off a session with ESRI where the technician did a screen share

to look at my setup. His take was the problem was that I had added a

shapefile, and he coached me through adding a feature service through

ArcGIS Desktop. That seems to work, at least for now. He was unable to

explain either why the functionality is available to add a shapefile, if

I'm not supposed to do that, nor why after several hours it did work

anyway. He repeatedly told me that I can't make shapefiles editable, only

feature services, and seemed not to understand that Saturday I had both

made the shapefiles editable and edited them on the iToys, with the changes

eventually appearing on ArcGIS Online.

All this occurred hours after me sending the question, or I wouldn't have

asked.

I'm wanting really badly to like this. So far it is kinda hard....

0 Kudos
JoeFlannery
Regular Contributor II

Bryce:

Have you Enabled Offline Mode in the map setting properties?

0 Kudos
by Anonymous User
Not applicable

Who knows? All I know is, several hours after submitting the question, I

was able to edit from my iToys, without further action on my part.

Supposing I were to do such a thing, where would I find the map setting

properties?

0 Kudos
JoeFlannery
Regular Contributor II

"View Item Details" from the map's drop-down in your My Content area.

0 Kudos
by Anonymous User
Not applicable

Thanks, that worked.

What is typical lag time to sync iToys? I went to ArcGIS online & deleted

all my blundering play toys from Saturday & added the data as a feature

service from ArcGIS Desktop, and created a new map with full editing

privileges, per Danny's instruction in the screen-share session this

morning. It has been maybe half an hour. My iPhone shows two of

Saturday's projects but not today's. The iPad shows all four of

Saturday's, but not today's. I've turned off the "push only" button, and

both toys are connected to WiFi.

0 Kudos
JoeFlannery
Regular Contributor II

To refresh the Collector App, I double-press the Home button on the iPad, swipe up or down to close the Collector App, go back to the Home screen, re-enter the Collector app and you should get a Refresh of your maps.

0 Kudos
by Anonymous User
Not applicable

That worked on the iPad. So far, neither that nor a hard shut down/restart

has worked for the iPhone 6. But I expect eventually it will wake up and

smell the coffee.

0 Kudos