Failed to download offline area - over slow connections

159
2
11-13-2020 12:41 PM
Regular Contributor

Enterprise 10.7.1, we cannot download offline areas when the latency between the remote user and the GIS Server machine is high. The remote Collector user get a generic error "Failed to download the offline area". We tried both Android Collector and new Field Maps apps.

Users a few states away have issues even on Wifi. Any tips here?

Reply
0 Kudos
2 Replies
Esri Contributor

Does this occur with ArcGIS Pro ( This uses the same workflow as collector) or collector on the same network where ArcGIS enterprise is located? If this works as expected this would most likely be related to network latency. If a VPN is involved then the user will usually have a slower connection due to the routing it must take to access internal services.

Does this happen with only this webmap or all webmaps?

If you are able to download dataset you can try working with smaller datasets or have the user download this dataset on a better internet connection.

Reply
0 Kudos
Regular Contributor

This was a router issue with our network. The primary router has a DNS Host record for ourgisportal.domain.com that pointed to the GIS Web Adapter's internal IP, 192.168.1.25. Then, internal LAN clients can use the Portal website just as if they are accessing it from outside the network when they are actually not.

Problem was, that DNS host record did NOT have reverse DNS enabled. As soon as it was enabled, the problem went away. In speaking with ESRI support, I recommended this gets added to the Enterprise config. docs; I've never seen reverse DNS listed as a requirement.

Reply
0 Kudos