Difficulty setting mode offline on collector for arcgis

306
4
07-16-2020 05:40 AM
solenemasseron
New Contributor
Dear all,
I am trying to set up Arcgis Collector using Arcgis Portal of my Organization. I would like to use it in offline mode but I can’t manage to set my web map to be compatible.
Here is my workflow :
1- On Arcmap I create a versioned layer of multiple polygons in WGS84, with a Global ID.
2-Then I publish the service in features layers so that I can subsequently modify it.
3-I allow the following operations: create, update, delete, extract, query and synchronize.

Using these parameters and the tutos of ESRI, I don't succeed in finding where the problem comes from. Am I missing a step knowing that in my webmap I already have a background map specific to my Organization (and that the problem may lie here)? I downloaded it for I downloaded to step up a background plan in tpk on the mobile app.
0 Kudos
4 Replies
MiaogengZhang
Esri Regular Contributor

Could you check if your basemap supports offline? Here is some help doc might help

Prepare for offline data collection—ArcGIS Collector | Documentation 

0 Kudos
solenemasseron
New Contributor

Hello,

Thank you very much for your answer I will look.
On the other hand, I thought that by publishing the feature layer with these criteria, I should see the properties window if I could activate the offline mode or not. Is it after the publication?

0 Kudos
KearyLarson2
Occasional Contributor

Were you able to resolve the issues you were having?  I've been going through the documentation and I'm finding the process confusing to set up a layer for editing in ArcGIS Collector offline. I haven't figured it out yet

0 Kudos
ChristopherBowering
Occasional Contributor

I too am currently trying to use disconnected/offline editing with Collector via editable layers published thru my organizational Portal.  I've read thru some of the ESRI docs on preparing data for offline editing and preparing maps for offline editing.  My data is registered as versioned; editing capabilities are all checked on when publishing; I add the feature layer to a Portal WebMap; the WebMap has the "use in Collector" checkbox checked on under the settings.  However, when I open Collector (Desktop or iPad) and click on the 3-dot ellipsis next to the map, only the "details" option is available.  There is no longer a "download area" option.  I haven't attempted to do this in maybe 8 months or so but the last time I tried, I had no problem downloading an area for offline editing.

Any thoughts?  Thanks!

0 Kudos