Collector / Field Maps - show date/time in local zone when in the app

395
6
Jump to solution
05-12-2021 08:44 PM
LidiaDudina2
New Contributor III

Hello All,

I am setting up my map to be used in Collector/Field Maps.

The data is in sde and we are running Enterprise 10.7.1.

The layers time is set to  'no time':

LidiaDudina2_2-1620877008437.png

 

The date/time comes from editor tracking field and the time there is set to UTC. 

LidiaDudina2_1-1620876952585.png

 

Published service on ArcGIS Server, in service settings, Parameters, the Date Field Setting Time Zone is set to 'None'. I tried UTC and local time zone but it did not change the outcome. 

LidiaDudina2_3-1620877118931.png

With these settings, when I view collected data in a web map or in ArcGIS Pro, the date/time is shown as local time. So if I added a point and checked right away in the web map, when it was created, it says 'just now.

However, when I view the same point in Collector/Field Map, it say 10 hours ago (we are in +10 hours Time Zone). And no matter how I change the settings above, I can't get it to say 'just now' or few minutes ago (e.g. local time) for just now collected data. It keeps showing date/time in UTC. Is there a way to get Collector/Field map to display date/time as local time zone?

 

0 Kudos
1 Solution

Accepted Solutions
ShelleySchott
Esri Contributor

@LidiaDudina2 , you may need to disable and re-enable the Editor Tracking for the feature class in the Enterprise Geodatabase.

I would use the GP tools from the Toolbox in ArcGIS Pro. The Editor Tracking tools are found in the Data Management Tools - Fields toolbox. You do need to release all locks on the database and stop all services to do this task.

Shelley Schott
Senior Consultant, Esri Australia

View solution in original post

0 Kudos
6 Replies
ShelleySchott
Esri Contributor

@LidiaDudina2 , When you enable Editor Tracking, you will have an option to select either UTC or Database time. This means that the Date Modified and Updated Date fields in the database will either be captured as UTC or Database time.

https://pro.arcgis.com/en/pro-app/latest/help/data/geodatabases/overview/introduction-to-editor-trac... 

Has your data be enabled for versioning? Is it Traditional Versioning or Branch Versioning?

If you are using Branch Versioning, you will only be able to set editor tracking to UTC.

Shelley Schott
Senior Consultant, Esri Australia
0 Kudos
LidiaDudina2
New Contributor III

 It the menu where you select UTC or database time, I can't change it, it is  grayed out for me:

LidiaDudina2_0-1621303356270.png

In the database connection properties, the versioning is set to traditional:

LidiaDudina2_1-1621303483457.png

 

0 Kudos
ShelleySchott
Esri Contributor

@LidiaDudina2 , you may need to disable and re-enable the Editor Tracking for the feature class in the Enterprise Geodatabase.

I would use the GP tools from the Toolbox in ArcGIS Pro. The Editor Tracking tools are found in the Data Management Tools - Fields toolbox. You do need to release all locks on the database and stop all services to do this task.

Shelley Schott
Senior Consultant, Esri Australia

View solution in original post

0 Kudos
LidiaDudina2
New Contributor III

Thank you @ShelleySchott 

I've have re-done the Editor Tracking via Geoprocessing Tools in ArcGIS Pro, I was able to set the Editor Tracking Time to database time. 

However when I use collector and create a new feature, the time is still 10 hours behind.

When editing in a web map, the created time is in our local time zone.

0 Kudos
ShelleySchott
Esri Contributor

Have you changed the timezone setting for the service in ArcGIS Server Manager?

ShelleySchott_0-1621567030462.png

If this has been set, it maybe worth logging a support ticket with your local Esri Support team to do further troubleshooting.

Shelley Schott
Senior Consultant, Esri Australia
0 Kudos
LidiaDudina2
New Contributor III

Hi @ShelleySchott 

This is now working as required. I've used your advice and run the tool "disable editor tracking" on all dataset. I then run the tool "enable editor tracking" and enabled user tracking with time in database time.

I have also changed the service time zone to UTC (in arcgis server manager/parameters/Date Field Setting).

After both of these changes, date/time displays in local time in Collector, web based maps and ArcGIS Pro.

Thank you so much for your help!

0 Kudos