Collector does not recognize the maps I created in ArcGIS online

2047
4
01-14-2016 06:21 AM
KimHiller
New Contributor II

I followed the instructions from the tutorial on how to publish features and how to create a map on ArcGIS online.  I also followed the directions for configuring the data collection form.  The last thing I did was save and share the map I created.  When I open and log in to collector, the screen indicates I don't have any maps.  Please help!

0 Kudos
4 Replies
RussellRoberts1
Esri Frequent Contributor

Your map must contain a feature service that is editable. So if you are are uploading a shapefile to ArcGIS Online you must check the box that will publish it as a feature service and add the feature service to the map with editing enabled. If you add a hosted feature service through "Add Item with Full Editing Control" this only enables editing on the service for that session you are using the web map, it will not propagate out to other users of the map or into the Collector app. Also when you share a map for other members of your org to use, it must be shared to a group that these other members are a part of.

Cheers

Russ

KimHiller
New Contributor II

Thank you for your response Russ.

I have uploaded a shapefile to ArcGIS Online and it tells me that the source is a feature service, but in the details it says editing is disabled. I have tried uploading other shapefiles, but I do not see a box to check for adding the feature service to the map with editing enabled during the uploading process.

Kim

0 Kudos
RussellRoberts1
Esri Frequent Contributor

So if your feature service says editing disabled on the feature service item detail page. Click Edit and at the bottom of the page you can choose to enable editing. Then Click Save and your service will now be editable.

Reopen the map after you do this and re-save it. This will make the map ready for Collector and on iOS you can pull to refresh to grab your new maps and on Android the option you be presented in the drop down menu to refresh your gallery.

0 Kudos
KimHiller
New Contributor II

It worked!!! Thank you

Kim