Collector app editor tracking. Is it working?

1823
2
07-01-2016 08:04 AM
VickyShort
Occasional Contributor

Hi

We have recently had some field staff sync their devices and I have noticed the editor tracking fields are no longer being populated. Has anyone else had this problem since the arc online update?

Thank you

Vicky

0 Kudos
2 Replies
AikoWeverka1
New Contributor II

We've also been experiencing absence of data in editor tracking fields (but only intermittently) over the past week. It's been happening for different users across different maps and different feature layers, so difficult to pinpoint the exact error. We'd be curious to know if anyone else has experienced something similar?

0 Kudos
AC2
by
New Contributor

We just hit that problem too on a new installation of 10.4 Portal + Server. It seems that the new version of Portal + Server tries to populate field names that are different from the editor tracking template provided on the ESRI website. The old field names were "Creator", "Creator Date", etc. while the new field names are "created_user", "created_date", etc.

The best way is to create a new feature class in SDE without using the template AND also enable editor tracking for it in ArcCatalog BEFORE publishing it as a service. Doing that will let ArcCatalog create the correct field names that the new version Portal + Server can populate.

If you want to keep using the current feature class, then navigate to it using ArcCatalog and Enable Editor Tracking from there. It is not as clean though since it will add a bunch of fields in addition to what you already have there.

This took us a few days to work out 😕 I think we need to file a bug report on that!

Hope it helps!

0 Kudos